summaryrefslogtreecommitdiff
path: root/tests/test-string-nr
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-string-nr')
-rw-r--r--tests/test-string-nr/Makefile.am46
-rw-r--r--tests/test-string-nr/scanner.l96
2 files changed, 0 insertions, 142 deletions
diff --git a/tests/test-string-nr/Makefile.am b/tests/test-string-nr/Makefile.am
deleted file mode 100644
index 1b06765..0000000
--- a/tests/test-string-nr/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-string-nr
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT)
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-string-nr/scanner.l b/tests/test-string-nr/scanner.l
deleted file mode 100644
index 6ab5b54..0000000
--- a/tests/test-string-nr/scanner.l
+++ /dev/null
@@ -1,96 +0,0 @@
-/*
- * This file is part of flex.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * Neither the name of the University nor the names of its contributors
- * may be used to endorse or promote products derived from this software
- * without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
- * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
- * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE.
- */
-
-%{
-/* A template scanner file to build "scanner.c". */
-#include <stdio.h>
-#include <stdlib.h>
-#include "config.h"
-
-#define NUMBER 200
-#define WORD 201
-
-%}
-
-%option 8bit outfile="scanner.c" prefix="test"
-%option nounput nomain nodefault noyywrap
-%option warn
-
-
-%%
-
-[[:space:]]+ { }
-[[:digit:]]+ { printf("NUMBER "); fflush(stdout);}
-[[:alpha:]]+ { printf("WORD "); fflush(stdout);}
-. {
- fprintf(stderr,"*** Error: Unrecognized character '%c' while scanning.\n",
- yytext[0]);
- yyterminate();
- }
-
-<<EOF>> { printf("<<EOF>>\n"); yyterminate();}
-
-%%
-
-
-#define INPUT_STRING_1 "1234 foo bar"
-#define INPUT_STRING_2 "1234 foo bar *@&@&###@^$#&#*"
-
-int main(void);
-
-int
-main ()
-{
- char * buf;
- int len;
- YY_BUFFER_STATE state;
-
-
- /* Scan a good string. */
- printf("Testing: yy_scan_string(%s): ",INPUT_STRING_1); fflush(stdout);
- state = yy_scan_string ( INPUT_STRING_1 );
- yylex();
- yy_delete_buffer(state);
-
- /* Scan only the first 12 chars of a string. */
- printf("Testing: yy_scan_bytes(%s): ",INPUT_STRING_2); fflush(stdout);
- state = yy_scan_bytes ( INPUT_STRING_2, 12 );
- yylex();
- yy_delete_buffer(state);
-
- /* Scan directly from a buffer.
- We make a copy, since the buffer will be modified by flex.*/
- printf("Testing: yy_scan_buffer(%s): ",INPUT_STRING_1); fflush(stdout);
- len = strlen(INPUT_STRING_1) + 2;
- buf = (char*)malloc( len );
- strcpy( buf, INPUT_STRING_1);
- buf[ len -2 ] = 0; /* Flex requires two NUL bytes at end of buffer. */
- buf[ len -1 ] =0;
-
- state = yy_scan_buffer( buf, len );
- yylex();
- yy_delete_buffer(state);
-
- printf("TEST RETURNING OK.\n");
- return 0;
-}