summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Campbell <ijc@debian.org>2018-12-16 13:55:37 +0000
committerIan Campbell <ijc@debian.org>2018-12-16 13:56:22 +0000
commit95a220dc19851b9bc435aa97b48aefc4f3ff46aa (patch)
treed4a356116750b17ea628c1475f0d2bcfb1a311cf
parent038a9ffa918256862ffb88481462d7d024be88bf (diff)
Pass `--no-recusion` earlier in `tar`'s command line.
(Closes: #872057)
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/71_duplicate_files_in_tar.dpatch28
3 files changed, 38 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index fb13fc6..9b37dcd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+flexbackup (1.2.1-6.4) UNRELEASED; urgency=medium
+
+ * Non-maintainer upload.
+ * Pass `--no-recursion` earlier in the comand-line when calling out to `tar`
+ since the argument now only applies to arguments which follow it. Thanks to
+ Florian Schmidt for diagnosing and providing a patch. (Closes: #872057)
+
+ -- Ian Campbell <ijc@debian.org> Sun, 16 Dec 2018 13:52:26 +0000
+
flexbackup (1.2.1-6.3) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/patches/00list b/debian/patches/00list
index d3d56ac..df8899b 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -9,3 +9,4 @@
50_lzma_support
60_use_afio_default_nocompression
70_no_defined_on_hash
+71_duplicate_files_in_tar.dpatch
diff --git a/debian/patches/71_duplicate_files_in_tar.dpatch b/debian/patches/71_duplicate_files_in_tar.dpatch
new file mode 100644
index 0000000..a31f092
--- /dev/null
+++ b/debian/patches/71_duplicate_files_in_tar.dpatch
@@ -0,0 +1,28 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 71_duplicate_files_in_tar.dpatch by Florian Schmidt <debian@fajs.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Bug #872057 patch by Florian Schmidt <debian@fajs.de>
+## DP:
+## DP: This is due to a change in the behavior of tar's --no-recursion option.
+## DP: In either 1.28 or 1.29, it was changed to only apply to all options
+## DP: *following* it. Since the flexbackup command line has --files-from
+## DP: before --no-recursion, the --no-recursion is effectively ignored. (See
+## DP: also bug #829738)
+
+@DPATCH@
+--- a/flexbackup 2018-03-07 21:51:57.950379925 +0100
++++ b/flexbackup 2018-03-07 21:52:17.418333887 +0100
+@@ -1405,11 +1405,11 @@
+ $cmd .= "| ";
+
+ $cmd .= "$::path{tar} --create ";
++ $cmd .= "--no-recursion ";
+ $cmd .= "--null ";
+ $cmd .= "--files-from=- ";
+ $cmd .= "--ignore-failed-read ";
+ $cmd .= "--same-permissions ";
+- $cmd .= "--no-recursion ";
+ $cmd .= "--totals ";
+ if ($cfg::label ne 'false') {
+ if (length($title) > $::tar_max_label) {