summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2019-02-10 22:06:41 -0500
committerAaron M. Ucko <ucko@debian.org>2019-02-10 23:09:12 -0500
commit2bb28d1e11eee40478c0e6aac933782f55d63320 (patch)
treec694e37a3b44fe6ba448b5ff800d0fe9794e8350
parentb8440500660eb1accd4ce7ec07e822f243fc2fbb (diff)
Advance to Debhelper 11, albeit with (dh_)autoreconf reined in.
* configure: Revert local changes in favor of using (dh_)autoreconf. * debian/compat: Go ahead and advance to 11. * debian/control: Advance debhelper B-D version constraint to (>= 11~). * debian/rules: Allow (dh_)autoreconf, albeit with autoheader suppressed, and configure saved and restored rather than deleted on cleanup.
-rw-r--r--.gitignore1
-rwxr-xr-xconfigure35
-rw-r--r--debian/.gitignore2
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat2
-rw-r--r--debian/control2
-rw-r--r--debian/patches/debian-changes110
-rwxr-xr-xdebian/rules12
8 files changed, 40 insertions, 131 deletions
diff --git a/.gitignore b/.gitignore
index a169202..f1014ef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
.pc
FL/Makefile
+autom4te.cache
config.*
documentation/*.[0-9]
documentation/fltk.p*
diff --git a/configure b/configure
index b663e7d..ecdbae1 100755
--- a/configure
+++ b/configure
@@ -1957,10 +1957,10 @@ if test x$enable_shared = xyes; then
FLDSONAME="libfltk_forms.so.$FL_API_VERSION"
GLDSONAME="libfltk_gl.so.$FL_API_VERSION"
IMGDSONAME="libfltk_images.so.$FL_API_VERSION"
- DSOCOMMAND="\$(CXX) \$(DSOFLAGS) -Wl,-soname,\$@ -shared -fPIC $DEBUGFLAG -o"
-# if test "x$libdir" != "x/usr/lib"; then
-# DSOLINK="-Wl,-rpath,$libdir"
-# fi
+ DSOCOMMAND="\$(CXX) \$(DSOFLAGS) -Wl,-soname,\$@ \$(LDLIBS) -shared -fPIC $DEBUGFLAG -o"
+ if test "x$libdir" != "x/usr/lib"; then
+ DSOLINK="-Wl,-rpath,$libdir"
+ fi
;;
AIX*)
DSONAME="libfltk_s.a"
@@ -7926,7 +7926,6 @@ _ACEOF
fi
-SAVELIBS=$LIBS
{ echo "$as_me:$LINENO: checking for library containing dlsym" >&5
echo $ECHO_N "checking for library containing dlsym... $ECHO_C" >&6; }
if test "${ac_cv_search_dlsym+set}" = set; then
@@ -8146,7 +8145,6 @@ _ACEOF
fi
-LIBS=$SAVELIBS
AUDIOLIBS=""
@@ -8773,8 +8771,8 @@ echo "$as_me: WARNING: Cannot find system z lib or header: choosing the local li
else
ZLIBINC=""
ZLIB=""
- # LIBS="-lz $LIBS"
- # IMAGELIBS="-lz $IMAGELIBS"
+ LIBS="-lz $LIBS"
+ IMAGELIBS="-lz $IMAGELIBS"
STATICIMAGELIBS="-lz $STATICIMAGELIBS"
cat >>confdefs.h <<\_ACEOF
#define HAVE_LIBZ 1
@@ -9523,7 +9521,6 @@ _ACEOF
break
fi
done
- LIBS=$SAVELIBS
fi
fi
@@ -11236,7 +11233,7 @@ echo "$as_me: error: Configure could not find required X11 libraries" >&2;}
echo "$as_me: WARNING: Ignoring libraries \"$X_PRE_LIBS\" requested by configure." >&2;}
fi
- LIBS="$LIBS -lX11 $X_EXTRA_LIBS"
+ LIBS="$LIBS -lXext -lX11 $X_EXTRA_LIBS"
CFLAGS="$CFLAGS $X_CFLAGS"
CXXFLAGS="$CXXFLAGS $X_CFLAGS"
LDFLAGS="$X_LIBS $LDFLAGS"
@@ -11797,12 +11794,12 @@ if test $ac_cv_header_GL_glu_h = yes; then
#define HAVE_GL_GLU_H 1
_ACEOF
- # if test x$ac_cv_lib_GL_glXMakeCurrent = xyes; then
- # GLLIB="-lGLU $GLLIB"
- # fi
- # if test x$ac_cv_lib_MesaGL_glXMakeCurrent = xyes; then
- # GLLIB="-lMesaGLU $GLLIB"
- # fi
+ if test x$ac_cv_lib_GL_glXMakeCurrent = xyes; then
+ GLLIB="-lGLU $GLLIB"
+ fi
+ if test x$ac_cv_lib_MesaGL_glXMakeCurrent = xyes; then
+ GLLIB="-lMesaGLU $GLLIB"
+ fi
fi
@@ -12083,7 +12080,7 @@ if test "${ac_cv_lib_Xft_XftDrawCreate+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lXft -lfontconfig $LIBS"
+LIBS="-lXft $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -12143,7 +12140,7 @@ if test $ac_cv_lib_Xft_XftDrawCreate = yes; then
#define USE_XFT 1
_ACEOF
- LIBS="-lXft -lfontconfig $LIBS"
+ LIBS="-lXft $LIBS"
fi
fi
@@ -12661,7 +12658,7 @@ _ACEOF
else
cat >>confdefs.h <<_ACEOF
-#define FLTK_DOCDIR "$prefix/share/doc/fltk1.1-doc/HTML"
+#define FLTK_DOCDIR "$prefix/share/doc/fltk"
_ACEOF
fi
diff --git a/debian/.gitignore b/debian/.gitignore
index b8af0e2..98a21d2 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -1,6 +1,8 @@
*.debhelper
*.debhelper.log
*.substvars
+autoreconf.*
+configure.saved
debhelper-build-stamp
files
fltk1.1-doc
diff --git a/debian/changelog b/debian/changelog
index 5c3821b..90804c9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,13 @@
fltk1.1 (1.1.10-26) UNRELEASED; urgency=medium
* NOT RELEASED YET.
+ * configure: Revert local changes in favor of using (dh_)autoreconf.
+ * debian/compat: Go ahead and advance to 11.
+ * debian/control: Advance debhelper B-D version constraint to (>= 11~).
+ * debian/rules: Allow (dh_)autoreconf, albeit with autoheader suppressed,
+ and configure saved and restored rather than deleted on cleanup.
- -- Aaron M. Ucko <ucko@debian.org> Sun, 10 Feb 2019 21:53:26 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Sun, 10 Feb 2019 22:06:40 -0500
fltk1.1 (1.1.10-25) unstable; urgency=medium
diff --git a/debian/compat b/debian/compat
index f599e28..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-10
+11
diff --git a/debian/control b/debian/control
index dd0ad31..b226622 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: fltk1.1
Maintainer: Aaron M. Ucko <ucko@debian.org>
Section: libs
Priority: optional
-Build-Depends: debhelper (>= 10~),
+Build-Depends: debhelper (>= 11~),
libgl1-mesa-dev | libgl-dev,
libglu1-mesa-dev | libglu-dev,
libjpeg-dev,
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index 7726cde..f12d1f3 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -1,9 +1,10 @@
Combined patches from git.
--- /dev/null
+++ fltk1.1-1.1.10/.gitignore
-@@ -0,0 +1,98 @@
+@@ -0,0 +1,99 @@
+.pc
+FL/Makefile
++autom4te.cache
+config.*
+documentation/*.[0-9]
+documentation/fltk.p*
@@ -158,113 +159,6 @@ Combined patches from git.
portable-dist:
epm -v -s fltk.xpm fltk
---- fltk1.1-1.1.10.orig/configure
-+++ fltk1.1-1.1.10/configure
-@@ -1957,10 +1957,10 @@ if test x$enable_shared = xyes; then
- FLDSONAME="libfltk_forms.so.$FL_API_VERSION"
- GLDSONAME="libfltk_gl.so.$FL_API_VERSION"
- IMGDSONAME="libfltk_images.so.$FL_API_VERSION"
-- DSOCOMMAND="\$(CXX) \$(DSOFLAGS) -Wl,-soname,\$@ \$(LDLIBS) -shared -fPIC $DEBUGFLAG -o"
-- if test "x$libdir" != "x/usr/lib"; then
-- DSOLINK="-Wl,-rpath,$libdir"
-- fi
-+ DSOCOMMAND="\$(CXX) \$(DSOFLAGS) -Wl,-soname,\$@ -shared -fPIC $DEBUGFLAG -o"
-+# if test "x$libdir" != "x/usr/lib"; then
-+# DSOLINK="-Wl,-rpath,$libdir"
-+# fi
- ;;
- AIX*)
- DSONAME="libfltk_s.a"
-@@ -7926,6 +7926,7 @@ _ACEOF
- fi
-
-
-+SAVELIBS=$LIBS
- { echo "$as_me:$LINENO: checking for library containing dlsym" >&5
- echo $ECHO_N "checking for library containing dlsym... $ECHO_C" >&6; }
- if test "${ac_cv_search_dlsym+set}" = set; then
-@@ -8145,6 +8146,7 @@ _ACEOF
- fi
-
-
-+LIBS=$SAVELIBS
-
- AUDIOLIBS=""
-
-@@ -8771,8 +8773,8 @@ echo "$as_me: WARNING: Cannot find syste
- else
- ZLIBINC=""
- ZLIB=""
-- LIBS="-lz $LIBS"
-- IMAGELIBS="-lz $IMAGELIBS"
-+ # LIBS="-lz $LIBS"
-+ # IMAGELIBS="-lz $IMAGELIBS"
- STATICIMAGELIBS="-lz $STATICIMAGELIBS"
- cat >>confdefs.h <<\_ACEOF
- #define HAVE_LIBZ 1
-@@ -9521,6 +9523,7 @@ _ACEOF
- break
- fi
- done
-+ LIBS=$SAVELIBS
- fi
- fi
-
-@@ -11233,7 +11236,7 @@ echo "$as_me: error: Configure could not
- echo "$as_me: WARNING: Ignoring libraries \"$X_PRE_LIBS\" requested by configure." >&2;}
- fi
-
-- LIBS="$LIBS -lXext -lX11 $X_EXTRA_LIBS"
-+ LIBS="$LIBS -lX11 $X_EXTRA_LIBS"
- CFLAGS="$CFLAGS $X_CFLAGS"
- CXXFLAGS="$CXXFLAGS $X_CFLAGS"
- LDFLAGS="$X_LIBS $LDFLAGS"
-@@ -11794,12 +11797,12 @@ if test $ac_cv_header_GL_glu_h = yes; th
- #define HAVE_GL_GLU_H 1
- _ACEOF
-
-- if test x$ac_cv_lib_GL_glXMakeCurrent = xyes; then
-- GLLIB="-lGLU $GLLIB"
-- fi
-- if test x$ac_cv_lib_MesaGL_glXMakeCurrent = xyes; then
-- GLLIB="-lMesaGLU $GLLIB"
-- fi
-+ # if test x$ac_cv_lib_GL_glXMakeCurrent = xyes; then
-+ # GLLIB="-lGLU $GLLIB"
-+ # fi
-+ # if test x$ac_cv_lib_MesaGL_glXMakeCurrent = xyes; then
-+ # GLLIB="-lMesaGLU $GLLIB"
-+ # fi
-
- fi
-
-@@ -12080,7 +12083,7 @@ if test "${ac_cv_lib_Xft_XftDrawCreate+s
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lXft $LIBS"
-+LIBS="-lXft -lfontconfig $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -12140,7 +12143,7 @@ if test $ac_cv_lib_Xft_XftDrawCreate = y
- #define USE_XFT 1
- _ACEOF
-
-- LIBS="-lXft $LIBS"
-+ LIBS="-lXft -lfontconfig $LIBS"
- fi
-
- fi
-@@ -12658,7 +12661,7 @@ _ACEOF
-
- else
- cat >>confdefs.h <<_ACEOF
--#define FLTK_DOCDIR "$prefix/share/doc/fltk"
-+#define FLTK_DOCDIR "$prefix/share/doc/fltk1.1-doc/HTML"
- _ACEOF
-
- fi
--- fltk1.1-1.1.10.orig/configure.in
+++ fltk1.1-1.1.10/configure.in
@@ -202,10 +202,10 @@ if test x$enable_shared = xyes; then
diff --git a/debian/rules b/debian/rules
index a1b06f8..175846a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,17 @@ GAMES = blocks checkers sudoku
EXTRA_MFLAGS = OPTIM="$(CFLAGS) $(XCFLAGS)" STRIP=@:
%:
- dh $@ --without autoreconf
+ dh $@
+
+override_dh_autoreconf:
+ -mv configure debian/configure.saved
+# FLTK uses a hand-maintained configh.in and an autoheader-unfriendly
+# configure.ac.
+ AUTOHEADER=/bin/true dh_autoreconf
+
+override_dh_autoreconf_clean:
+ dh_autoreconf_clean
+ [ -e configure ] || mv debian/configure.saved configure
override_dh_auto_configure:
mv fltk.spec fltk.spec.saved