summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2019-02-10 22:31:28 -0500
committerAaron M. Ucko <ucko@debian.org>2019-02-10 23:09:12 -0500
commit7a11ac411bc4d1ebee368fcf9c874455f8ecda7d (patch)
tree8b5384901bad9b8cde9dae9bed6383870718ae56
parent5c5ef7c080753bf32e257e868ad215290c560720 (diff)
debian/rules: Use host-specific pkg-config per H. Grohne (#914480).
Use host-specific pkg-config in FTCONFIG for the sake of cross builds, per Helmut Grohne.
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/rules3
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 0862d5b..51beba6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,8 +9,10 @@ fltk1.1 (1.1.10-26) UNRELEASED; urgency=medium
configure saved and restored rather than deleted on cleanup.
- Use /usr/share/dpkg/{architecture,buildflags}.mk instead of calling
dpkg-{architecture,buildflags} directly (and piecemeal).
+ - Use host-specific pkg-config in FTCONFIG for the sake of cross
+ builds, per Helmut Grohne. (Closes: #914480.)
- -- Aaron M. Ucko <amu@ucko.debian.net> Sun, 10 Feb 2019 22:25:38 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Sun, 10 Feb 2019 22:31:27 -0500
fltk1.1 (1.1.10-25) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index 6c3684f..69a0569 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,7 @@ include /usr/share/dpkg/buildflags.mk
XCFLAGS = -Wall -Wunused -Wno-format-y2k -fPIE -fno-strict-aliasing
+PKG_CONFIG = /usr/bin/$(DEB_HOST_GNU_TYPE)-pkg-config
libdir = /usr/lib/$(DEB_HOST_MULTIARCH)
GAMES = blocks checkers sudoku
EXTRA_MFLAGS = OPTIM="$(CFLAGS) $(XCFLAGS)" STRIP=@:
@@ -26,7 +27,7 @@ override_dh_autoreconf_clean:
override_dh_auto_configure:
mv fltk.spec fltk.spec.saved
- dh_auto_configure -- FTCONFIG="/usr/bin/pkg-config freetype2" \
+ dh_auto_configure -- FTCONFIG="$(PKG_CONFIG) freetype2" \
DSOFLAGS="$(filter-out -fPIE -pie,$(LDFLAGS))" \
--enable-shared --enable-threads --enable-xft \
--enable-xinerama --without-links --libdir=$(libdir) \