summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/debian-changes16
2 files changed, 15 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 68cca99..51a6cc8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,5 @@
-fltk1.1 (1.1.10-23) UNRELEASED; urgency=medium
+fltk1.1 (1.1.10-23) unstable; urgency=medium
- * NOT YET RELEASED.
* debian/control:
- Canonicalize with the help of cme fix. In particular, declare
Standards-Version: 3.9.8 (already compliant, not that cme checked).
@@ -18,7 +17,7 @@ fltk1.1 (1.1.10-23) UNRELEASED; urgency=medium
* fltk-config.in: Filter out -D*, -f*, and -W*, not just -g* and -O* (but
leave --optim output alone for reference). (See #828081.)
- -- Aaron M. Ucko <ucko@debian.org> Tue, 24 Jan 2017 23:24:09 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Tue, 24 Jan 2017 23:25:20 -0500
fltk1.1 (1.1.10-22) unstable; urgency=medium
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index 6b9ddd4..7726cde 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -471,16 +471,26 @@ Combined patches from git.
if test "$echo_cflags" = "yes"; then
- echo $includes $CFLAGS
-+ echo "$includes $CFLAGS" | sed -e 's/ -[gO][^ ]*//g'
++ echo "$includes $CFLAGS" | sed -e 's/ -[DfgOW][^ ]*//g'
fi
if test "$echo_cxxflags" = "yes"; then
- echo $includes $CXXFLAGS
-+ echo "$includes $CXXFLAGS" | sed -e 's/ -[gO][^ ]*//g'
++ echo "$includes $CXXFLAGS" | sed -e 's/ -[DfgOW][^ ]*//g'
fi
if test "$echo_optim" = "yes"; then
-@@ -318,25 +319,26 @@ if test "$echo_ldstaticflags" = "yes"; t
+@@ -310,33 +311,34 @@ if test "$echo_ldflags" = "yes"; then
+ fi
+ fi
+ done
+- echo $libdirs $my_libs
++ echo " $libdirs $my_libs" | sed -e 's/ -W[^ ]*//g' -e 's/^ *//'
+ fi
+
+ if test "$echo_ldstaticflags" = "yes"; then
+- echo $LDSTATIC
++ echo " $LDSTATIC " | sed -e 's/ -W[^ ]*//g' -e 's/^ *//'
fi
if test "$echo_libs" = "yes"; then