summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2017-02-13 22:26:36 -0500
committerAaron M. Ucko <ucko@debian.org>2017-02-13 22:26:36 -0500
commit6f73807ca4ad2cefc969deb1020b88674f2fb2a6 (patch)
treebe144984d964fe0634e2426ff19ca7983ac9b04d
parent4fe2953181a9b8a04b6f87d3708d335aad7a5687 (diff)
1.3.4-3: Fully honor FLTK_SKIP_FLUID (#855040).debian/1.3.4-3archive/debian/1.3.4-3
debian/fix-fltk-targets-noconfig: Append logic to refrain from enforcing the existence of fluid in FLTK_SKIP_FLUID mode, based on a suggestion from Gianfranco Costamagna <locutusofborg@d.o>. (Closes: #855040.)
-rw-r--r--debian/changelog9
-rwxr-xr-xdebian/fix-fltk-targets-noconfig9
2 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index cc7571f..6e491ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+fltk1.3 (1.3.4-3) unstable; urgency=medium
+
+ * debian/fix-fltk-targets-noconfig: Append logic to refrain from
+ enforcing the existence of fluid in FLTK_SKIP_FLUID mode, based
+ on a suggestion from Gianfranco Costamagna <locutusofborg@d.o>.
+ (Closes: #855040.)
+
+ -- Aaron M. Ucko <ucko@debian.org> Mon, 13 Feb 2017 22:26:35 -0500
+
fltk1.3 (1.3.4-2) unstable; urgency=medium
* debian/fix-fltk-targets-noconfig: Update for current CMake output
diff --git a/debian/fix-fltk-targets-noconfig b/debian/fix-fltk-targets-noconfig
index e223940..8ef02d7 100755
--- a/debian/fix-fltk-targets-noconfig
+++ b/debian/fix-fltk-targets-noconfig
@@ -23,3 +23,12 @@ while (<>) {
}
print;
}
+
+print <<EOF;
+
+# Don't enforce the existence of fluid when asked to skip it.
+# (See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=855040.)
+if(FLTK_SKIP_FLUID)
+ list(REMOVE_ITEM _IMPORT_CHECK_TARGETS fluid)
+endif()
+EOF