summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2015-12-31 15:24:56 -0500
committerAaron M. Ucko <ucko@debian.org>2015-12-31 16:18:39 -0500
commit00353e9020286daf7dd3af37a703ed18278b1198 (patch)
tree0e823d8fcdc3509da7116a9ef5656149264faa0a
parentbc5eee3cb884f75cb22e56505326b483141253f1 (diff)
Invoke cmake -DOPTION_BUILD_EXAMPLES:BOOL=OFF to work around #809535.
-rw-r--r--debian/changelog9
-rwxr-xr-xdebian/rules3
2 files changed, 7 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 3829c69..53ee5ac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,9 +2,10 @@ fltk1.3 (1.3.3-5) UNRELEASED; urgency=medium
* NOT YET RELEASED.
* debian/control: Split some build dependencies out into Build-Depends-Arch.
- * debian/rules: Streamline indep-only (-A) builds to the extent possible
- (limited by the need to build and run fluid for the sake of some
- installed examples).
+ * debian/rules:
+ - Streamline indep-only (-A) builds to the extent possible (limited by the
+ need to build and run fluid for the sake of some installed examples).
+ - Invoke cmake -DOPTION_BUILD_EXAMPLES:BOOL=OFF to work around #809535.
* debian/source/options: Rename back from local-options, per dgit.
* debian/.gitignore: Unignore patches, per dgit.
* debian/*.menu: Retire in favor of .desktop files, per #741573.
@@ -12,7 +13,7 @@ fltk1.3 (1.3.3-5) UNRELEASED; urgency=medium
https://wiki.debian.org/ReproducibleBuilds/TimestampsInPDFGeneratedByLaTeX
plus an additional tweak to address the use of \today.
- -- Aaron M. Ucko <ucko@debian.org> Thu, 31 Dec 2015 14:49:12 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Thu, 31 Dec 2015 15:24:56 -0500
fltk1.3 (1.3.3-4) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index b2f30a9..ae9d7e7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,7 +35,8 @@ ifneq "" "$(filter libfltk1.3-dev, $(shell dh_listpackages))"
mkdir CMakeTmp
cd CMakeTmp && cmake -DCC:STRING="$(CC)" -DCXX:STRING="$(CXX)" \
-DCMAKE_INSTALL_PREFIX:STRING=/usr -DOPTION_CAIRO:BOOL=ON \
- -DOPTION_BUILD_SHARED_LIBS:BOOL=ON -DOPTION_CREATE_LINKS:BOOL=ON ..
+ -DOPTION_BUILD_SHARED_LIBS:BOOL=ON -DOPTION_CREATE_LINKS:BOOL=ON \
+ -DOPTION_BUILD_EXAMPLES:BOOL=OFF ..
sed -e 's/ STATIC /_STATIC&/' \
CMakeTmp/CMakeFiles/Export/lib/fltk/FLTK-Targets.cmake \
> CMakeTmp/etc/FLTK-Targets.cmake