summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2016-02-14 22:31:54 -0500
committerAaron M. Ucko <ucko@debian.org>2016-02-14 22:32:16 -0500
commit76e034bb7f4e4452de853f3bc4c06c3dd553b1b4 (patch)
treed5b1987b3a82532de4798c90ff49a9a4e248293b
parent4c050810a54fa0e07297a6bb7a7608ed9747a826 (diff)
debian/rules: Fix indep-only (-A) builds. (Closes: #814434.)
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules12
2 files changed, 11 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index ef405ef..1b32d80 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,13 @@
fltk1.3 (1.3.3-7) UNRELEASED; urgency=medium
* NOT RELEASED YET.
+ * debian/rules: Fix indep-only (-A) builds. (Closes: #814434.)
* documentation/Makefile: Postprocess Doxygen LaTeX output to avoid
breakage from attempting to use \hyperlink within \caption.
* documentation/src/fltk-book.tex.in: Drop an occurrence of \\ that has
become invalid with Doxygen 1.8.11.
- -- Aaron M. Ucko <ucko@debian.org> Sun, 14 Feb 2016 21:03:53 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Sun, 14 Feb 2016 22:31:54 -0500
fltk1.3 (1.3.3-6) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index 0fd8f90..b77ea0e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,8 @@ override_dh_auto_clean:
override_dh_clean:
rm -rf CMakeTmp
- dh_clean documentation/doxygen_sqlite3.db fltk-config.unhardened
+ dh_clean documentation/doxygen_sqlite3.db fltk-config.unhardened \
+ common-build-stamp
chmod +x debian/fix-fltk-targets-noconfig
override_dh_auto_configure:
@@ -55,11 +56,16 @@ endif
--libdir=$(libdir)
mv fltk.spec.saved fltk.spec
-override_dh_auto_build:
+common-build-stamp:
dh_auto_build -- OPTIM="$(CFLAGS) $(XCFLAGS)" STRIP=@:
- -$(MAKE) -C documentation all html pdf
+ touch $@
+
+override_dh_auto_build-arch: common-build-stamp
cp -f fltk-config.unhardened fltk-config
+override_dh_auto_build-indep: common-build-stamp
+ $(MAKE) -C documentation html pdf
+
override_dh_auto_install-arch:
dh_auto_install -a
mkdir -p debian/tmp/usr/games