summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2015-07-07 01:32:55 -0400
committerAaron M. Ucko <ucko@debian.org>2015-07-07 01:40:11 -0400
commit574b357ee8bd5c44a1511a5a29f60b2d659b263f (patch)
treee7f69d70ef4c9414325db8cca0b4e7b56ee7c81a /Makefile
parent51a046516db7c8e194cc232e4fb18ecb3ffa65dc (diff)
parenta3d0ced57399c9fd8075377b7310d545f968e524 (diff)
Merge tag 'upstream/1.3.3' (Closes: #791346.)
Upstream version 1.3.3
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 0e3a832..56cf736 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile 8864 2011-07-19 04:49:30Z greg.ercolano $"
+# "$Id: Makefile 10224 2014-08-01 20:56:09Z greg.ercolano $"
#
# Top-level makefile for the Fast Light Tool Kit (FLTK).
#
@@ -60,13 +60,13 @@ depend: makeinclude
clean:
-$(RM) core *.o
- for dir in $(DIRS); do\
+ for dir in examples $(DIRS); do\
echo "=== cleaning $$dir ===";\
(cd $$dir; $(MAKE) $(MFLAGS) clean) || exit 1;\
done
distclean: clean
- $(RM) config.*
+ $(RM) config.h config.log config.status
$(RM) fltk-config fltk.list makeinclude
$(RM) fltk.spec
$(RM) FL/Makefile
@@ -90,7 +90,7 @@ fltk-config: configure configh.in fltk-config.in
touch config.h
chmod +x fltk-config
-makeinclude: configure configh.in makeinclude.in
+makeinclude: configure configh.in makeinclude.in config.guess config.sub
if test -f config.status; then \
./config.status --recheck; \
./config.status; \
@@ -103,6 +103,11 @@ makeinclude: configure configh.in makeinclude.in
# configure: configure.in
# autoconf
+config.guess config.sub:
+ -automake --add-missing 2> /dev/null
+ if [ ! -e config.sub ]; then echo NOTE: Using frozen copy of config.sub; cp misc/config.sub . ; fi
+ if [ ! -e config.guess ]; then echo NOTE: Using frozen copy of config.guess; cp misc/config.guess . ; fi
+
portable-dist:
epm -v -s fltk.xpm fltk
@@ -126,5 +131,5 @@ clang-changes:
#
-# End of "$Id: Makefile 8864 2011-07-19 04:49:30Z greg.ercolano $".
+# End of "$Id: Makefile 10224 2014-08-01 20:56:09Z greg.ercolano $".
#