summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2007-05-20 01:20:30 +0000
committerAaron M. Ucko <ucko@debian.org>2007-05-20 01:20:30 +0000
commitda5f6f8dd1f87d32cea2f882d251ebaecc3c7629 (patch)
tree5772cc71ce588e5cbdbb7e458e2c5876dcbc8fcc /Makefile
parentee19f9cc1847049ccb983313bb11df47d253df16 (diff)
parent9b5d5801c27165ad47245acb580f30b8ce2d20b4 (diff)
Merge new upstream snapshot / release candidate (1.1.8~r5840) into trunk.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 7445743..ca6f410 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile 4756 2006-01-15 18:36:16Z mike $"
+# "$Id: Makefile 5788 2007-05-01 14:28:23Z matt $"
#
# Top-level makefile for the Fast Light Tool Kit (FLTK).
#
@@ -38,8 +38,7 @@ all: makeinclude
install: makeinclude
-mkdir -p $(DESTDIR)$(bindir)
$(RM) $(DESTDIR)$(bindir)/fltk-config
- -cp fltk-config $(DESTDIR)$(bindir)
- -chmod 755 $(DESTDIR)$(bindir)/fltk-config
+ $(INSTALL_SCRIPT) fltk-config $(DESTDIR)$(bindir)
for dir in FL $(DIRS); do\
echo "=== installing $$dir ===";\
(cd $$dir; $(MAKE) $(MFLAGS) install) || exit 1;\
@@ -78,9 +77,11 @@ clean:
distclean: clean
$(RM) config.*
$(RM) fltk-config fltk.list makeinclude
+ $(RM) fltk.spec
$(RM) FL/Makefile
$(RM) documentation/*.$(CAT1EXT)
$(RM) documentation/*.$(CAT3EXT)
+ $(RM) documentation/*.$(CAT6EXT)
$(RM) documentation/fltk.pdf
$(RM) documentation/fltk.ps
$(RM) -r documentation/fltk.d
@@ -108,7 +109,9 @@ portable-dist:
native-dist:
epm -v -f native fltk
+etags:
+ etags FL/*.H FL/*.h src/*.cxx src/*.c src/*.h fluid/*.h fluid/*.cxx test/*.h test/*.cxx
#
-# End of "$Id: Makefile 4756 2006-01-15 18:36:16Z mike $".
+# End of "$Id: Makefile 5788 2007-05-01 14:28:23Z matt $".
#