summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2007-12-14 21:39:47 +0000
committerAaron M. Ucko <ucko@debian.org>2007-12-14 21:39:47 +0000
commitef14f4c1f787fd07090d737dc740757dfe1f90ee (patch)
treeeae19e2ed7686e5f7a026bb5075e39f69911015e /configure.in
parentef7969d2e482cd3872dd7f11edafb66f6a4770ac (diff)
Adjust shared library linkage per dpkg-shlibdeps's new warnings. The
only remaining warnings concern libm, which g++ pulls in even when not explicitly asked to.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 07d5b4a..8f6ccfb 100644
--- a/configure.in
+++ b/configure.in
@@ -171,7 +171,7 @@ if test x$enable_shared = xyes; then
FLDSONAME="libfltk_forms.so.$FL_API_VERSION"
GLDSONAME="libfltk_gl.so.$FL_API_VERSION"
IMGDSONAME="libfltk_images.so.$FL_API_VERSION"
- DSOCOMMAND="\$(CXX) -Wl,-soname,\$@ \$(LDLIBS) -shared -fPIC $DEBUGFLAG -o"
+ DSOCOMMAND="\$(CXX) -Wl,-soname,\$@ -shared -fPIC $DEBUGFLAG -o"
# if test "x$libdir" != "x/usr/lib"; then
# DSOLINK="-Wl,-rpath,$libdir"
# fi
@@ -531,7 +531,7 @@ have_pthread=no
if test "x$enable_threads" = xyes; then
AC_CHECK_HEADER(pthread.h, AC_DEFINE(HAVE_PTHREAD_H))
- AC_CHECK_LIB(pthread, pthread_create)
+ AC_CHECK_LIB(pthread, pthread_create, :)
if test "x$ac_cv_lib_pthread_pthread_create" = xyes -a x$ac_cv_header_pthread_h = xyes; then
have_pthread=yes
@@ -712,7 +712,7 @@ case $uname in
AC_CHECK_HEADER(X11/Xft/Xft.h,
AC_CHECK_LIB(Xft, XftDrawCreate,
AC_DEFINE(USE_XFT)
- LIBS="-lXft $LIBS"))
+ LIBS="-lXft -lfontconfig $LIBS", [], -lfontconfig))
fi
fi