summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Godfrey-Kittle <jamesgk@google.com>2015-11-25 12:23:20 -0800
committerJames Godfrey-Kittle <jamesgk@google.com>2015-11-25 12:23:20 -0800
commit5283037a5e665164ae9ca0fb8261758c7c1cc9d8 (patch)
tree5d4daed26a5fa7cbe5d608510a9ffefc4f611e0d
parent0b96a9418ddec3c573f1a5e8705fe9e4d4324904 (diff)
[fontcrunch] Stricter compilation of quadopt
I feel like we may as well have these flags, since it compiles fine with them.
-rw-r--r--third_party/fontcrunch/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/third_party/fontcrunch/Makefile b/third_party/fontcrunch/Makefile
index 2090d39..3a073ec 100644
--- a/third_party/fontcrunch/Makefile
+++ b/third_party/fontcrunch/Makefile
@@ -20,7 +20,7 @@ OPT = $(patsubst %.bez, %.bezopt, $(SRC))
dummy: $(OPT)
quadopt: quadopt.cc
- $(CXX) $< -std=c++0x -O3 -o $@
+ $(CXX) $< -std=c++0x -O3 -Werror -Wall -o $@
%.bezopt: %.bez quadopt
./quadopt $< $@
@@ -29,4 +29,4 @@ clean:
rm -f quadopt
find . -name '*.bez' -delete
find . -name '*.bezopt' -delete
- rmdir ?? \ No newline at end of file
+ rmdir ??