summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Godfrey-Kittle <jamesgk@google.com>2015-11-23 14:40:51 -0800
committerJames Godfrey-Kittle <jamesgk@google.com>2015-11-23 14:40:51 -0800
commitcc9999078ad8dd324b6e38baa9e390510361b189 (patch)
tree44346d4763ed719954a6cad7288c3f0415775c0f
parent09eb72c1feecd1c997c8cccc47532440717e4a5f (diff)
Update readme
-rw-r--r--README.md40
1 files changed, 7 insertions, 33 deletions
diff --git a/README.md b/README.md
index 039db7e..37ca75a 100644
--- a/README.md
+++ b/README.md
@@ -26,6 +26,7 @@ cd $HOME/roboto-src
```bash
git clone https://github.com/google/roboto.git
git clone https://github.com/behdad/fonttools.git
+git clone https://github.com/jamesgk/ufo2ft.git
git clone https://github.com/robofab-developers/robofab.git
git clone https://github.com/typesupply/feaTools.git
git clone https://github.com/typemytype/booleanOperations.git
@@ -39,11 +40,7 @@ via:
sudo apt-get install cython
```
-##### For OTF generation:
-
-```bash
-git clone https://github.com/typesupply/ufo2fdk.git
-```
+##### For OTF/TTF generation:
To build the FDK yourself:
@@ -59,12 +56,6 @@ If you're not building the FDK yourself, download the pre-built version
[here](http://www.adobe.com/devnet/opentype/afdko.html) and unzip it into the
current directory.
-##### For TTF generation, on Ubuntu:
-
-```bash
-sudo apt-get install fontforge python-fontforge
-```
-
##### For post-production:
```bash
@@ -85,6 +76,8 @@ You can install the necessary modules at the sytem level:
```bash
cd fonttools
sudo python setup.py install
+cd ../ufo2ft
+sudo python setup.py install
cd ../robofab
sudo python setup.py install
cd ../feaTools
@@ -100,6 +93,7 @@ Or set `$PYTHONPATH` locally before running `make`:
```bash
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/fonttools/Lib"
+PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/ufo2ft/Lib"
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/robofab/Lib"
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/feaTools/Lib"
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/booleanOperations/Lib"
@@ -107,18 +101,6 @@ PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/booleanOperations/Lib"
##### For OTF generation:
-```bash
-cd ufo2fdk
-sudo python setup.py install
-cd ..
-```
-
-Or:
-
-```bash
-PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/ufo2fdk/Lib"
-```
-
If building the FDK yourself, follow the instructions in `afdko/FDK/FDK Build Notes.txt`:
```bash
@@ -201,10 +183,10 @@ The Roboto build toolchain depends on:
glyph overlap removal.
- (requires Cython to install: http://cython.org/)
-## OTF Generation
+## OTF/TTF Generation
OTF generation depends on:
-- ufo2fdk (https://github.com/typesupply/ufo2fdk)
+- ufo2ft (https://github.com/jamesgk/ufo2tk)
- Open-source portions of the AFDKO
(https://github.com/adobe-type-tools/afdko/releases)
@@ -213,14 +195,6 @@ the variety which includes closed-source tools
(http://www.adobe.com/devnet/opentype/afdko.html), though these closed-source
portions are not used to build Roboto.
-## TTF Generation
-TTF generation depends on:
-
-- FontForge (https://github.com/fontforge/fontforge)
-
-Whose Python interface should be available on Ubuntu by default via `apt-get
-install fontforge python-fontforge`.
-
## Post-Production
Post-production scripts (most of the code outside of the `fontbuild` directory,
e.g. for testing output) depend on: