summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChristian Robertson <robertsonc@google.com>2014-05-19 16:09:20 -0700
committerChristian Robertson <robertsonc@google.com>2014-05-19 16:09:20 -0700
commit7051939fa74b5f8f453be605f5dc3b4c23e1d1d9 (patch)
tree65cb31b34a64b2b07f9f6fd1bcb58d9a4945a92d /Makefile
Importing Roboto 2.0
Diffstat (limited to 'Makefile')
-rwxr-xr-xMakefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100755
index 0000000..c145e46
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+
+all: sans slab mono
+
+sans:
+ echo "BASEDIR=\"$(CURDIR)\"" > /tmp/makefonts.flw
+ cat "scripts/build.py" >> /tmp/makefonts.flw
+ open -nWa "$(FONTLAB)" /tmp/makefonts.flw
+
+v2:
+ echo "BASEDIR=\"$(CURDIR)\"" > /tmp/makefontsB.flw
+ cat "scripts/build-v2.py" >> /tmp/makefontsB.flw
+ open -nWa "$(FONTLAB)" /tmp/makefontsB.flw
+
+
+slab:
+ echo "BASEDIR=\"$(CURDIR)\"" > /tmp/makefonts.flw
+ cat "scripts/build-slab.py" >> /tmp/makefonts.flw
+ open -nWa "$(FONTLAB)" /tmp/makefonts.flw
+
+slabitalic:
+ echo "BASEDIR=\"$(CURDIR)\"" > /tmp/makefonts.flw
+ cat "scripts/build-slabitalic.py" >> /tmp/makefonts.flw
+ open -nWa "$(FONTLAB)" /tmp/makefonts.flw
+
+mono:
+ echo "BASEDIR=\"$(CURDIR)\"" > /tmp/makefonts.flw
+ cat "scripts/build-monoV2.py" >> /tmp/makefonts.flw
+ open -nWa "$(FONTLAB)" /tmp/makefonts.flw