summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRoozbeh Pournader <roozbeh@google.com>2014-07-27 08:53:45 -0700
committerRoozbeh Pournader <roozbeh@google.com>2014-07-27 08:53:45 -0700
commit1178d3463a527ff1d37de312ea9d040ea726a359 (patch)
treefdd6923bee26f30cbff28f2d223cb77b24bea6a7 /Makefile
parent54bfaf54e7eb1fd074a68127c11f4248748a09c8 (diff)
Add Makefile and .gitignore rules for fontcrunch.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4062ad4..17bbcb7 100644
--- a/Makefile
+++ b/Makefile
@@ -27,6 +27,17 @@ mono:
cat "scripts/build-monoV2.py" >> /tmp/makefonts.flw
open -nWa "$(FONTLAB)" /tmp/makefonts.flw
+crunch:
+ mkdir -p out/crunched
+ cd third_party/fontcrunch && \
+ for source in ../../out/RobotoTTF/*.ttf ../../out/RobotoCondensedTTF/*.ttf; do \
+ python fontcrunch.py gen $$source; \
+ done && \
+ $(MAKE) -j24 && \
+ for source in ../../out/RobotoTTF/*.ttf ../../out/RobotoCondensedTTF/*.ttf; do \
+ python fontcrunch.py pack $$source out/crunched/$$(basename $$source) >/dev/null; \
+ done
+
android:
mkdir -p out/android
for source in out/RobotoTTF/*.ttf out/RobotoCondensedTTF/*.ttf; do \