summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRoozbeh Pournader <roozbeh@google.com>2014-12-01 22:02:51 -0800
committerJames Godfrey-Kittle <jamesgk@google.com>2015-04-16 12:16:23 -0700
commit5ed29bb54cd0153d2a927c4fb12ac5d9095acd38 (patch)
tree85ab557968f7da630e36ce7e6be88ec63f473dac /Makefile
parent6ca0d935997f3a1f1bd53169a6b2f10ab4ae75d3 (diff)
Expand scripts for webfont generation.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index f6da6a0..05196fa 100644
--- a/Makefile
+++ b/Makefile
@@ -58,12 +58,11 @@ web:
mkdir -p out/web
for source in hinted/*.ttf; do \
touched=$$(mktemp); \
- subsetted=$$(mktemp); \
final=out/web/$$(basename $$source); \
+ final="$${final/Roboto/RobotoDraft}"; \
python scripts/touchup_for_web.py $$source $$touched && \
- python scripts/subset_for_web.py $$touched $$subsetted && \
- python scripts/force_yminmax.py $$subsetted $$final && \
- rm $$touched $$subsetted; \
+ python scripts/subset_for_web.py $$touched $$final && \
+ rm $$touched; \
done
test: test-android test-coverage test-general