summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRoozbeh Pournader <roozbeh@google.com>2014-12-08 09:21:48 -0800
committerJames Godfrey-Kittle <jamesgk@google.com>2015-04-16 12:16:23 -0700
commit62764abc5eed32c1e319f19fd9737bbe7f81ed2e (patch)
tree9efe9643b5468cad88d5d896a5b5a465b34e6a94 /Makefile
parentda5be226f7a8a4704c7967acba311c6857f0cee3 (diff)
Add target for ChromeOS fonts.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 05196fa..cde362b 100644
--- a/Makefile
+++ b/Makefile
@@ -60,11 +60,21 @@ web:
touched=$$(mktemp); \
final=out/web/$$(basename $$source); \
final="$${final/Roboto/RobotoDraft}"; \
- python scripts/touchup_for_web.py $$source $$touched && \
+ python scripts/touchup_for_web.py $$source $$touched RobotoDraft && \
python scripts/subset_for_web.py $$touched $$final && \
rm $$touched; \
done
+chromeos:
+ mkdir -p out/chromeos
+ for source in hinted/*.ttf; do \
+ touched=$$(mktemp); \
+ final=out/chromeos/$$(basename $$source); \
+ python scripts/touchup_for_web.py $$source $$touched Roboto && \
+ python $$HOME/noto/nototools/subset.py $$touched $$final && \
+ rm $$touched; \
+ done
+
test: test-android test-coverage test-general
test-general: