summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRoozbeh Pournader <roozbeh@google.com>2014-07-24 18:41:33 -0700
committerRoozbeh Pournader <roozbeh@google.com>2014-07-24 18:41:33 -0700
commita8df15d7b96363a6652c5fd4d6dd95db99647326 (patch)
tree9e190c3d0a1c123e06b04e591955be8fe7392eba /Makefile
parent3a8f38ed8e34c6021444f2ef43527a8f3ded09df (diff)
Add the beginning of a test infrastructure.
We now test for expected values of yMin and yMax, and equal widths for digits.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 6e359d3..4062ad4 100644
--- a/Makefile
+++ b/Makefile
@@ -33,12 +33,17 @@ android:
touched=$$(mktemp); \
subsetted=$$(mktemp); \
final=out/android/$$(basename $$source); \
- python scripts/touchup_for_android.py $$source $$touched; \
- python $$HOME/noto/nototools/subset.py $$touched $$subsetted; \
- python scripts/force_yminmax.py $$subsetted $$final; \
+ python scripts/touchup_for_android.py $$source $$touched && \
+ python $$HOME/noto/nototools/subset.py $$touched $$subsetted && \
+ python scripts/force_yminmax.py $$subsetted $$final && \
rm $$touched $$subsetted; \
done
glass: out/android/Roboto-Thin.ttf
mkdir -p out/glass
python scripts/touchup_for_glass.py $< out/glass/Roboto-Thin.ttf
+
+test: test-android
+
+test-android:
+ python scripts/run_android_tests.py