summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--scripts/build-v2.py7
2 files changed, 6 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index fad70c6..070467b 100644
--- a/Makefile
+++ b/Makefile
@@ -15,9 +15,7 @@
all: v2
v2:
- echo "BASEDIR=\"$(CURDIR)\"" > /tmp/makefontsB.py
- cat "scripts/build-v2.py" >> /tmp/makefontsB.py
- python /tmp/makefontsB.py
+ PYTHONPATH=$(PYTHONPATH):$(CURDIR)/scripts/lib python scripts/build-v2.py
crunch:
mkdir -p out/crunched
diff --git a/scripts/build-v2.py b/scripts/build-v2.py
index 15679e8..a861a76 100644
--- a/scripts/build-v2.py
+++ b/scripts/build-v2.py
@@ -13,10 +13,9 @@
# limitations under the License.
+import os
import sys
-sys.path.insert(0, "%s/scripts/lib" % BASEDIR)
-
from fontTools.misc.transform import Transform
from robofab.objects.objectsRF import RPoint
@@ -26,6 +25,10 @@ from fontbuild.italics import transformFLGlyphMembers
from fontbuild.mix import Master
from fontbuild.mix import Mix
+# The root of the Roboto tree
+BASEDIR = os.path.abspath(
+ os.path.join(os.path.dirname(__file__), os.pardir))
+
# Masters
rg = Master("%s/src/v2/Roboto_Regular.ufo" % BASEDIR)