summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--Makefile11
2 files changed, 13 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index c0f153e..d3861b1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,5 @@ _*.ignore
out/android
out/glass
+
+third_party/fontcrunch/[0-9a-f][0-9a-f]
diff --git a/Makefile b/Makefile
index 4062ad4..17bbcb7 100644
--- a/Makefile
+++ b/Makefile
@@ -27,6 +27,17 @@ mono:
cat "scripts/build-monoV2.py" >> /tmp/makefonts.flw
open -nWa "$(FONTLAB)" /tmp/makefonts.flw
+crunch:
+ mkdir -p out/crunched
+ cd third_party/fontcrunch && \
+ for source in ../../out/RobotoTTF/*.ttf ../../out/RobotoCondensedTTF/*.ttf; do \
+ python fontcrunch.py gen $$source; \
+ done && \
+ $(MAKE) -j24 && \
+ for source in ../../out/RobotoTTF/*.ttf ../../out/RobotoCondensedTTF/*.ttf; do \
+ python fontcrunch.py pack $$source out/crunched/$$(basename $$source) >/dev/null; \
+ done
+
android:
mkdir -p out/android
for source in out/RobotoTTF/*.ttf out/RobotoCondensedTTF/*.ttf; do \