summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile16
-rwxr-xr-xscripts/touchup_for_android.py10
2 files changed, 21 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index e485e34..66343db 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,22 @@ android:
rm $$touched $$subsetted; \
done
+# TODO: remove this build target once we are comfortable with the quality of
+# the new toolchain
+android-from-hinted:
+ mkdir -p out/android
+ for source in hinted/*.ttf; do \
+ unhinted=$$(mktemp); \
+ touched=$$(mktemp); \
+ subsetted=$$(mktemp); \
+ final=out/android/$$(basename $$source); \
+ python $$HOME/noto/nototools/drop_hints.py $$source $$unhinted && \
+ python scripts/touchup_for_android.py $$unhinted $$touched && \
+ python $$HOME/noto/nototools/subset.py $$touched $$subsetted && \
+ python scripts/force_yminmax.py $$subsetted $$final && \
+ rm $$touched $$subsetted; \
+ done
+
web:
mkdir -p out/web
for source in hinted/*.ttf; do \
diff --git a/scripts/touchup_for_android.py b/scripts/touchup_for_android.py
index bd21fc5..80b8e70 100755
--- a/scripts/touchup_for_android.py
+++ b/scripts/touchup_for_android.py
@@ -175,13 +175,13 @@ def apply_android_specific_fixes(font):
hhea.descent = -500
hhea.lineGap = 0
- # Remove tab, combining keycap, the arrows, and unassigned characters
- # from the cmap table
- # https://code.google.com/a/google.com/p/roboto/issues/detail?id=51
+ # Remove combining keycap and the arrows from the cmap table:
# https://code.google.com/a/google.com/p/roboto/issues/detail?id=52
- # https://code.google.com/a/google.com/p/roboto/issues/detail?id=53
font_data.delete_from_cmap(font, [
- 0x0009, 0x20E3, 0x2072, 0x2073, 0x208F, 0x2191, 0x2193])
+ 0x20E3, # COMBINING ENCLOSING KEYCAP
+ 0x2191, # UPWARDS ARROW
+ 0x2193, # DOWNWARDS ARROW
+ ])
# Drop tables not useful on Android
for table in ['LTSH', 'hdmx', 'VDMX', 'gasp']: