summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index e53cf90..f6da6a0 100644
--- a/Makefile
+++ b/Makefile
@@ -33,16 +33,16 @@ crunch:
for source in ../../out/RobotoTTF/*.ttf ../../out/RobotoCondensedTTF/*.ttf; do \
python fontcrunch.py gen $$source; \
done && \
- $(MAKE) -j24 && \
+ $(MAKE) -j8 && \
for source in ../../out/RobotoTTF/*.ttf ../../out/RobotoCondensedTTF/*.ttf; do \
python fontcrunch.py pack $$source ../../out/crunched/$$(basename $$source) >/dev/null; \
- done
+ done
android:
mkdir -p out/android
for source in out/crunched/*.ttf; do \
- touched=$$(mktemp); \
- subsetted=$$(mktemp); \
+ touched=$$(mktemp); \
+ subsetted=$$(mktemp); \
final=out/android/$$(basename $$source); \
python scripts/touchup_for_android.py $$source $$touched && \
python $$HOME/noto/nototools/subset.py $$touched $$subsetted && \
@@ -54,6 +54,18 @@ glass: out/android/Roboto-Thin.ttf
mkdir -p out/glass
python scripts/touchup_for_glass.py $< out/glass/Roboto-Thin.ttf
+web:
+ mkdir -p out/web
+ for source in hinted/*.ttf; do \
+ touched=$$(mktemp); \
+ subsetted=$$(mktemp); \
+ final=out/web/$$(basename $$source); \
+ python scripts/touchup_for_web.py $$source $$touched && \
+ python scripts/subset_for_web.py $$touched $$subsetted && \
+ python scripts/force_yminmax.py $$subsetted $$final && \
+ rm $$touched $$subsetted; \
+ done
+
test: test-android test-coverage test-general
test-general:
@@ -62,5 +74,8 @@ test-general:
test-android:
python scripts/run_android_tests.py
+test-web:
+ python scripts/run_web_tests.py
+
test-coverage:
python scripts/coverage_test.py