summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'README.md')
-rw-r--r--README.md45
1 files changed, 12 insertions, 33 deletions
diff --git a/README.md b/README.md
index 039db7e..08681f6 100644
--- a/README.md
+++ b/README.md
@@ -26,6 +26,8 @@ cd $HOME/roboto-src
```bash
git clone https://github.com/google/roboto.git
git clone https://github.com/behdad/fonttools.git
+git clone https://github.com/googlei18n/cu2qu.git
+git clone https://github.com/jamesgk/ufo2ft.git
git clone https://github.com/robofab-developers/robofab.git
git clone https://github.com/typesupply/feaTools.git
git clone https://github.com/typemytype/booleanOperations.git
@@ -39,11 +41,7 @@ via:
sudo apt-get install cython
```
-##### For OTF generation:
-
-```bash
-git clone https://github.com/typesupply/ufo2fdk.git
-```
+##### For OTF/TTF generation:
To build the FDK yourself:
@@ -59,12 +57,6 @@ If you're not building the FDK yourself, download the pre-built version
[here](http://www.adobe.com/devnet/opentype/afdko.html) and unzip it into the
current directory.
-##### For TTF generation, on Ubuntu:
-
-```bash
-sudo apt-get install fontforge python-fontforge
-```
-
##### For post-production:
```bash
@@ -85,6 +77,10 @@ You can install the necessary modules at the sytem level:
```bash
cd fonttools
sudo python setup.py install
+cd ../cu2qu
+sudo python setup.py install
+cd ../ufo2ft
+sudo python setup.py install
cd ../robofab
sudo python setup.py install
cd ../feaTools
@@ -100,6 +96,8 @@ Or set `$PYTHONPATH` locally before running `make`:
```bash
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/fonttools/Lib"
+PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/cu2qu/Lib"
+PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/ufo2ft/Lib"
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/robofab/Lib"
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/feaTools/Lib"
PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/booleanOperations/Lib"
@@ -107,18 +105,6 @@ PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/booleanOperations/Lib"
##### For OTF generation:
-```bash
-cd ufo2fdk
-sudo python setup.py install
-cd ..
-```
-
-Or:
-
-```bash
-PYTHONPATH="$PYTHONPATH:$HOME/roboto-src/ufo2fdk/Lib"
-```
-
If building the FDK yourself, follow the instructions in `afdko/FDK/FDK Build Notes.txt`:
```bash
@@ -201,10 +187,11 @@ The Roboto build toolchain depends on:
glyph overlap removal.
- (requires Cython to install: http://cython.org/)
-## OTF Generation
+## OTF/TTF Generation
OTF generation depends on:
-- ufo2fdk (https://github.com/typesupply/ufo2fdk)
+- ufo2ft (https://github.com/jamesgk/ufo2ft)
+- cu2qu (https://github.com/googlei18n/cu2qu)
- Open-source portions of the AFDKO
(https://github.com/adobe-type-tools/afdko/releases)
@@ -213,14 +200,6 @@ the variety which includes closed-source tools
(http://www.adobe.com/devnet/opentype/afdko.html), though these closed-source
portions are not used to build Roboto.
-## TTF Generation
-TTF generation depends on:
-
-- FontForge (https://github.com/fontforge/fontforge)
-
-Whose Python interface should be available on Ubuntu by default via `apt-get
-install fontforge python-fontforge`.
-
## Post-Production
Post-production scripts (most of the code outside of the `fontbuild` directory,
e.g. for testing output) depend on: