summaryrefslogtreecommitdiff
path: root/third_party/fontcrunch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/fontcrunch/Makefile')
-rw-r--r--third_party/fontcrunch/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/third_party/fontcrunch/Makefile b/third_party/fontcrunch/Makefile
new file mode 100644
index 0000000..e73ca38
--- /dev/null
+++ b/third_party/fontcrunch/Makefile
@@ -0,0 +1,31 @@
+# Copyright 2014 Google Inc. All rights reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# Contributor: Raph Levien
+
+SRC = $(wildcard */*.bz)
+OPT = $(patsubst %.bz, %.bzopt, $(SRC))
+
+dummy: $(OPT)
+
+quadopt: quadopt.cc
+ $(CXX) $< -O3 -o $@
+
+%.bzopt: %.bz quadopt
+ ./quadopt $< $@
+
+clean:
+ rm -f quadopt
+ find . -name '*.bz' -delete
+ find . -name '*.bzopt' -delete \ No newline at end of file