summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer Marin Rodrigues <josch@debian.org>2023-10-28 08:10:47 +0200
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2023-10-28 08:10:47 +0200
commit7133411199b47e342f4e26535798c2e026995d84 (patch)
tree2773bf330066b1da647aeaf454709213a9ff6b86
parent671bd508391c16ebc43085050f355fefb39962fc (diff)
debian/rules: build with FL_BUILD_TESTS=OFF with DEB_BUILD_OPTIONS=nocheck
-rwxr-xr-xdebian/rules13
1 files changed, 9 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index e6ef67a..fc736a7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,8 +13,13 @@ include /usr/share/dpkg/architecture.mk
%:
dh $@ --sourcedirectory=fuzzylite --builddirectory=fuzzylite/obj-$(DEB_HOST_GNU_TYPE)
+CONFOPTS += -DCMAKE_INSTALL_LIBDIR=lib/$(DEB_HOST_MULTIARCH)
+CONFOPTS += -DCMAKE_VERBOSE_MAKEFILE=true
+CONFOPTS += -DCMAKE_BUILD_RPATH_USE_ORIGIN=ON
+ifneq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
+ CONFOPTS += -DFL_BUILD_TESTS=OFF
+else
+ CONFOPTS += -DFL_BUILD_TESTS=ON
+endif
override_dh_auto_configure:
- dh_auto_configure -- -DCMAKE_INSTALL_LIBDIR=lib/$(DEB_HOST_MULTIARCH) -DCMAKE_VERBOSE_MAKEFILE=true -DFL_CPP11=ON -DCMAKE_BUILD_RPATH_USE_ORIGIN=ON
-
-override_dh_auto_test:
- dh_auto_test
+ dh_auto_configure -- $(CONFOPTS)