summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer Marin Rodrigues <josch@debian.org>2022-06-16 22:36:45 +0200
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2022-06-16 22:36:45 +0200
commitc15c079c56b660a998d3cef6c3b48d4fc7d6b076 (patch)
tree770d282a452285f7798e9eefe825f9a3ccfcf5b9
parentb127745793926936b8b52503db70a748f9aeceef (diff)
support building with gcc-12 (closes: #1012933)
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0001-fuzzylite-src-main.cpp-support-building-with-gcc-12.patch29
-rw-r--r--debian/patches/series1
3 files changed, 37 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c6864ce..f7384de 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+fuzzylite (6.0+dfsg-3.1) UNRELEASED; urgency=medium
+
+ * add patch from https://github.com/fuzzylite/fuzzylite/pull/108 to support
+ building with gcc-12 (closes: #1012933)
+
+ -- Johannes Schauer Marin Rodrigues <josch@debian.org> Thu, 16 Jun 2022 22:35:41 +0200
+
fuzzylite (6.0+dfsg-3) unstable; urgency=medium
* add debian/salsa-ci.yml
diff --git a/debian/patches/0001-fuzzylite-src-main.cpp-support-building-with-gcc-12.patch b/debian/patches/0001-fuzzylite-src-main.cpp-support-building-with-gcc-12.patch
new file mode 100644
index 0000000..ac0a8a3
--- /dev/null
+++ b/debian/patches/0001-fuzzylite-src-main.cpp-support-building-with-gcc-12.patch
@@ -0,0 +1,29 @@
+From d7d8de788f4475bc4d465faad50cb6f5e81f8629 Mon Sep 17 00:00:00 2001
+From: Johannes Schauer Marin Rodrigues <josch@mister-muffin.de>
+Date: Thu, 16 Jun 2022 22:22:29 +0200
+Subject: [PATCH] fuzzylite/src/main.cpp: support building with gcc-12
+
+ * std::set_unexpected() is removed in c++17
+ * We build with -Wall -Wextra -Werror and with gcc-12, using
+ std::set_unexpected will trigger the warning due to
+ -Werror=deprecated-declarations which in turn is treated as an error and
+ makes the build fail.
+---
+ fuzzylite/src/main.cpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/fuzzylite/src/main.cpp b/fuzzylite/src/main.cpp
+index 06ca139e..4465fbbe 100644
+--- a/fuzzylite/src/main.cpp
++++ b/fuzzylite/src/main.cpp
+@@ -21,7 +21,6 @@
+
+ int main(int argc, const char* argv[]) {
+ std::set_terminate(fl::Exception::terminate);
+- std::set_unexpected(fl::Exception::terminate);
+ ::signal(SIGSEGV, fl::Exception::signalHandler);
+ ::signal(SIGABRT, fl::Exception::signalHandler);
+ ::signal(SIGILL, fl::Exception::signalHandler);
+--
+2.36.1
+
diff --git a/debian/patches/series b/debian/patches/series
index 53ab6e3..d8925b1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
reproducible.patch
fix-tests.patch
when-testing-large-float-numbers-for-equ.patch
+0001-fuzzylite-src-main.cpp-support-building-with-gcc-12.patch