summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJohannes Schauer <josch@debian.org>2015-07-07 11:12:00 +0200
committerJohannes Schauer <josch@debian.org>2015-07-07 11:12:00 +0200
commitd210b3addc8ffed7214afd8c7882e700fbcc38c5 (patch)
treeded15607f7f24f83d2d0d7c542265c0a97af577a /debian/rules
fuzzylite (5.1+dfsg-1) unstable; urgency=medium
* new upstream version (Closes: #777858) * removed debian/patches/20140705-minor-improvements-on-building-script as upstream integrated it. Adjust build options in d/rules accordingly. * delete debian/patches/20140714-building-from-objects-just-once and debian/patches/20141027-fix-some-spelling as they have been applied upstream * install usr/lib/*/pkgconfig/fuzzylite.pc in fuzzylite-dev * SONAME bump from 5.0 to 5.1, so renaming libfuzzylite5.0 to libfuzzylite5.1 * add debian/patches/pkgconfig_installdir to install pkgconfig file in correct location # imported from the archive
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..11f8e56
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+%:
+ dh $@ --sourcedirectory=fuzzylite --parallel
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DCMAKE_INSTALL_LIBDIR=lib/$(DEB_HOST_MULTIARCH) -DCMAKE_VERBOSE_MAKEFILE=true
+
+override_dh_install:
+ dh_install --fail-missing
+
+get-orig-source:
+ uscan --noconf --verbose --rename --destdir=$(CURDIR) --check-dirname-level=0 --force-download --repack --compression=xz --download-current-version