summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules11
2 files changed, 15 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 78b325a..4bc4d3f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+fuzzylite (6.0+dfsg-2) UNRELEASED; urgency=medium
+
+ * instead of symlinking the examples directory, change the build directory
+ * set DPKG_EXPORT_BUILDFLAGS=1 for hardening
+
+ -- Johannes 'josch' Schauer <josch@debian.org> Tue, 29 Jan 2019 20:29:37 +0100
+
fuzzylite (6.0+dfsg-1) unstable; urgency=medium
* new upstream version
diff --git a/debian/rules b/debian/rules
index 44854b9..628231b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,17 @@
#!/usr/bin/make -f
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+# for DEB_HOST_GNU_TYPE and DEB_HOST_MULTIARCH
+include /usr/share/dpkg/architecture.mk
+# we build in a subdirectory of ./fuzzylite because the unit tests expect the
+# ./examples directory to be two levels above, see
+# https://github.com/fuzzylite/fuzzylite/issues/85
%:
- dh $@ --sourcedirectory=fuzzylite
+ dh $@ --sourcedirectory=fuzzylite --builddirectory=fuzzylite/obj-$(DEB_HOST_GNU_TYPE)
override_dh_auto_configure:
dh_auto_configure -- -DCMAKE_INSTALL_LIBDIR=lib/$(DEB_HOST_MULTIARCH) -DCMAKE_VERBOSE_MAKEFILE=true -DFL_CPP11=ON
@@ -14,7 +20,6 @@ override_dh_install:
dh_install --fail-missing
override_dh_auto_test:
- ln -s ./fuzzylite-6.0+dfsg/examples ../examples
dh_auto_test
get-orig-source: