summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 8 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 44854b9..628231b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,17 @@
#!/usr/bin/make -f
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+# for DEB_HOST_GNU_TYPE and DEB_HOST_MULTIARCH
+include /usr/share/dpkg/architecture.mk
+# we build in a subdirectory of ./fuzzylite because the unit tests expect the
+# ./examples directory to be two levels above, see
+# https://github.com/fuzzylite/fuzzylite/issues/85
%:
- dh $@ --sourcedirectory=fuzzylite
+ dh $@ --sourcedirectory=fuzzylite --builddirectory=fuzzylite/obj-$(DEB_HOST_GNU_TYPE)
override_dh_auto_configure:
dh_auto_configure -- -DCMAKE_INSTALL_LIBDIR=lib/$(DEB_HOST_MULTIARCH) -DCMAKE_VERBOSE_MAKEFILE=true -DFL_CPP11=ON
@@ -14,7 +20,6 @@ override_dh_install:
dh_install --fail-missing
override_dh_auto_test:
- ln -s ./fuzzylite-6.0+dfsg/examples ../examples
dh_auto_test
get-orig-source: