summaryrefslogtreecommitdiff
path: root/debian/changelog
blob: 4bc4d3fa01db18bbf7a7e9ca878785e119e5a6d6 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
fuzzylite (6.0+dfsg-2) UNRELEASED; urgency=medium

  * instead of symlinking the examples directory, change the build directory
  * set DPKG_EXPORT_BUILDFLAGS=1 for hardening

 -- Johannes 'josch' Schauer <josch@debian.org>  Tue, 29 Jan 2019 20:29:37 +0100

fuzzylite (6.0+dfsg-1) unstable; urgency=medium

  * new upstream version
  * install examples in fuzzylite package
  * SONAME change: replace libfuzzylite5.1v5 with libfuzzylite6.0
  * put libfuzzylite6.0 in section libs
  * disable pkgkde-symbolshelper: too little gain for all the work
  * use secure copyright-format-uri

 -- Johannes 'josch' Schauer <josch@debian.org>  Sun, 27 Jan 2019 15:49:39 +0100

fuzzylite (5.1+dfsg-5) unstable; urgency=medium

  * update symbols file using "pkgkde-symbolshelper batchpatch -v '5.1' *.log"
    and build logs for all architectures acquired via "getbuildlog fuzzylite
    '5.1\+dfsg-4'"

 -- Johannes Schauer <josch@debian.org>  Wed, 23 Nov 2016 22:48:59 +0000

fuzzylite (5.1+dfsg-4) unstable; urgency=medium

  * bump Standards-Version to 3.9.8 (no changes required)
  * start using pkgkde-symbolshelper
  * bump debhelper compat level to 10
  * d/rules: export DEB_BUILD_MAINT_OPTIONS = hardening=+all

 -- Johannes Schauer <josch@debian.org>  Wed, 23 Nov 2016 17:55:13 +0000

fuzzylite (5.1+dfsg-3.1) unstable; urgency=medium

  * Non-maintainer upload, with maintainer permission

  [ Steve Langasek ]
  * Fix up symbols file for symbols that are not part of the ABI and are
    optimized away at -O3 (Closes: #819142).

  [ Gianfranco Costamagna ]
  * Fix build failure with gcc-6 with upstream help (Closes: #811880)
  * Update symbols.

 -- Gianfranco Costamagna <locutusofborg@debian.org>  Sat, 13 Aug 2016 15:33:03 +0200

fuzzylite (5.1+dfsg-3) unstable; urgency=medium

  * let libfuzzylite5.1v5 replace libfuzzylite5.1 (Closes: #803357)
  * add debian/libfuzzylite5.1v5.symbols.optional to deal with all the
    libstdc++6/cxx11 junk symbols on 32 as well as on 64 bit arches

 -- Johannes Schauer <josch@debian.org>  Sun, 01 Nov 2015 10:34:42 +0100

fuzzylite (5.1+dfsg-2) unstable; urgency=medium

  * start using dgit git repositories and change Vcs-Browser and Vcs-Git
    field.
  * replace package libfuzzylite5.1 by libfuzzylite5.1v5 because of libstdc++6
    ABI changes (closes: #799818)

 -- Johannes Schauer <josch@debian.org>  Sun, 25 Oct 2015 22:27:15 +0100

fuzzylite (5.1+dfsg-1) unstable; urgency=medium

  * new upstream version (Closes: #777858)
  * removed debian/patches/20140705-minor-improvements-on-building-script as
    upstream integrated it. Adjust build options in d/rules accordingly.
  * delete debian/patches/20140714-building-from-objects-just-once and
    debian/patches/20141027-fix-some-spelling as they have been applied
    upstream
  * install usr/lib/*/pkgconfig/fuzzylite.pc in fuzzylite-dev
  * SONAME bump from 5.0 to 5.1, so renaming libfuzzylite5.0 to
    libfuzzylite5.1
  * add debian/patches/pkgconfig_installdir to install pkgconfig file in
    correct location

 -- Johannes Schauer <josch@debian.org>  Tue, 07 Jul 2015 11:12:00 +0200

fuzzylite (5.0+dfsg-3) unstable; urgency=medium

  * change my email in Uploaders field to josch@debian.org
  * add Vcs-Browser and Vcs-Git fields
  * d/watch: use repacksuffix and use dversionmangle instead of uversionmangle
  * d/rules: add get-orig-source target
  * change priority from extra to optional because it has no conflicts and is
    not a debug package

 -- Johannes Schauer <josch@debian.org>  Wed, 04 Feb 2015 14:14:39 +0100

fuzzylite (5.0+dfsg-2) unstable; urgency=medium

  * add patch 20141027-fix-some-spelling to fix some spelling mistakes until
    the next upstream release
  * bump Standards-Version to 3.9.6. No changes needed.

 -- Johannes Schauer <j.schauer@email.de>  Sun, 16 Nov 2014 22:14:30 +0100

fuzzylite (5.0+dfsg-1) unstable; urgency=low

  * Initial release. (Closes: #761075)

 -- Johannes Schauer <j.schauer@email.de>  Mon, 01 Sep 2014 21:25:35 +0200