summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog11
-rw-r--r--debian/source/lintian-overrides3
-rw-r--r--debian/tests/control2
-rwxr-xr-xdebian/tests/link-to-library34
4 files changed, 47 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 4b87cc7..76f9da4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+fyba (4.1.1-6) unstable; urgency=medium
+
+ * Add a sensible autopkgtest which verifies that it is possible to
+ link with libfyba.
+ - Added these files:
+ debian/tests/control
+ debian/tests/link-to-library
+ * Remove lintian override for testsuite-autopkgtest-missing.
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Thu, 02 Aug 2018 20:28:34 +0200
+
fyba (4.1.1-5) unstable; urgency=medium
* Team upload.
diff --git a/debian/source/lintian-overrides b/debian/source/lintian-overrides
deleted file mode 100644
index d9d9775..0000000
--- a/debian/source/lintian-overrides
+++ /dev/null
@@ -1,3 +0,0 @@
-# Not worth the effort
-testsuite-autopkgtest-missing
-
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..ae5c47f
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,2 @@
+Tests: link-to-library
+Depends: libfyba-dev, g++
diff --git a/debian/tests/link-to-library b/debian/tests/link-to-library
new file mode 100755
index 0000000..2f09881
--- /dev/null
+++ b/debian/tests/link-to-library
@@ -0,0 +1,34 @@
+#!/bin/bash
+
+TMPDIR=`mktemp -d`
+
+
+cd ${TMPDIR}
+cat > source_file.cc << EOF
+#include <iostream>
+
+int main() {
+ std::cout << "Hello world. Just tested that it is possible to\nlink with -lfyba, -lfygm and -lfyut without\nanything written to stderr." << std::endl;
+}
+
+EOF
+
+RET=0
+
+g++ -o source_file source_file.cc -lfyba -lfygm -lfyut
+RETSTEP=$?
+if [ "$RETSTEP" != "0" ] ; then
+ RET=1
+fi
+
+./source_file
+RETSTEP=$?
+if [ "$RETSTEP" != "0" ] ; then
+ RET=1
+fi
+
+readelf -d ./source_file
+
+rm -rf ${TMPDIR}
+
+exit $RET