summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2021-10-07 16:16:13 +0200
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2021-10-07 16:16:13 +0200
commit62d834432fc37ad7931ac241aed873a1a297d56a (patch)
tree6a3d4474c229964b4a848f988390a539905b0e5b
parent9d10d422b5e7d72a39ccc11dd4d487ff193801ac (diff)
Fix cross-build usage of pkg-config
Closes: #979172
-rw-r--r--debian/patches/cross.patch23
-rw-r--r--debian/patches/series1
2 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/cross.patch b/debian/patches/cross.patch
new file mode 100644
index 0000000..a75c23f
--- /dev/null
+++ b/debian/patches/cross.patch
@@ -0,0 +1,23 @@
+Subject: Make pkg-config configurable
+Date: Sun, 3 Jan 2021 11:34:42 +0100
+From: Helmut Grohne <helmut@subdivi.de>
+
+gdigi fails to cross build from source, because the upstream Makefile
+hard codes the build architecture pkg-config. Making it substitutable is
+sufficient to making gdigi cross buildable.
+
+--- gdigi-0.4.0.orig/Makefile
++++ gdigi-0.4.0/Makefile
+@@ -1,9 +1,10 @@
+ CC = gcc
++PKG_CONFIG ?= pkg-config
+ EXTRA_CFLAGS ?=
+ EXTRA_LDFLAGS ?=
+-CFLAGS := $(shell pkg-config --cflags glib-2.0 gio-2.0 gtk+-3.0 libxml-2.0) -Wall -g -ansi -std=c99 $(EXTRA_CFLAGS)
++CFLAGS := $(shell $(PKG_CONFIG) --cflags glib-2.0 gio-2.0 gtk+-3.0 libxml-2.0) -Wall -g -ansi -std=c99 $(EXTRA_CFLAGS)
+ LDFLAGS = $(EXTRA_LDFLAGS) -Wl,--as-needed
+-LDADD := $(shell pkg-config --libs glib-2.0 gio-2.0 gtk+-3.0 gthread-2.0 alsa libxml-2.0) -lexpat -lm
++LDADD := $(shell $(PKG_CONFIG) --libs glib-2.0 gio-2.0 gtk+-3.0 gthread-2.0 alsa libxml-2.0) -lexpat -lm
+ OBJECTS = gdigi.o gui.o effects.o preset.o gtkknob.o preset_xml.o
+ DEPFILES = $(foreach m,$(OBJECTS:.o=),.$(m).m)
+
diff --git a/debian/patches/series b/debian/patches/series
index 82cf20c..54bb4ca 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
01-Modify-distclean-and-install-targets.patch
02-Update-categories-in-gdigi-desktop-file.patch
gcc-10.patch
+cross.patch