summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-01-03 02:42:25 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-01-03 03:48:49 -0800
commitb2451c719fe298e083c5ee70633d2390b26a198c (patch)
tree309a9fb222ae2f20105a18d41a7de10d2d52b726
parent4c60d7c31d6c0d0be9db24612ab0e5580e62be7b (diff)
debian/rules: Create a VERSION file since upstream expects it.
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 41568cb..a18e8c1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,6 @@
#!/usr/bin/make -f
+include /usr/share/dpkg/pkg-info.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
SHELL := sh -e
@@ -9,7 +10,10 @@ GFXBOOT_PATH = $(CURDIR)
%:
dh ${@} --parallel
-override_dh_auto_build:
+VERSION:
+ echo $(DEB_VERSION_UPSTREAM) > VERSION
+
+override_dh_auto_build: VERSION
dh_auto_build -- CFLAGS="$(CFLAGS) $(CPPFLAGS)"
LC_ALL=C.UTF-8 $(MAKE) -C doc doc
@@ -45,6 +49,7 @@ override_dh_auto_clean:
$(MAKE) -C doc clean
rm -rf build
+ rm -f VERSION
override_dh_auto_install:
dh_auto_install