summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-01-03 16:45:17 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-01-03 17:44:57 -0800
commit3c467ad2e870ee2c22fc708d0c43f4f0f35befb1 (patch)
treeec7bb5db93bca5876dbf2d5b7eb1c1dfa25884fd
parent65193274589faf5e2bc339fc696f31e8504edfd3 (diff)
debian/rules: Add target to update upstream changelog.
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index eda5154..4741e70 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,13 @@ VERSION:
changelog:
touch changelog
+update-upstream-changelog:
+ # Needs to be run manually upon new upstream versions
+ git checkout -b upstream-tmp-$(DEB_VERSION_UPSTREAM) $(DEB_VERSION_UPSTREAM) && ./git2log --changelog changelog
+ git checkout dgit/sid
+ git branch -d upstream-tmp-$(DEB_VERSION_UPSTREAM)
+ cp changelog changelog.upstream
+
override_dh_auto_build: VERSION changelog
dh_auto_build -- CFLAGS="$(CFLAGS) $(CPPFLAGS)"