summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2021-01-03 02:06:39 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-01-03 02:06:39 -0800
commit5a6d4627f1e0edf5b58297e28af58fb8d02ba4db (patch)
tree025d19727b981d2a551c63e11524a37aa8bf50d5
parent70bf4dd665d31475a8e9be0849a618df87168ed5 (diff)
gfxboot expects fonts to be in /usr/share/fonts/truetype et al,
not in subdirectories within like debian based systems do. The proper fix is to make search_font() in gfxboot-font recursive, however, for the time being we add the paths manually here. Gbp-Pq: Name 0007-ttf-dejavu.patch
-rw-r--r--themes/example_02/Makefile2
-rw-r--r--themes/example_03/Makefile2
-rw-r--r--themes/example_04/Makefile2
-rw-r--r--themes/example_05/Makefile2
-rw-r--r--themes/example_06/Makefile2
-rw-r--r--themes/example_07/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/themes/example_02/Makefile b/themes/example_02/Makefile
index 0fb4640..c0d551d 100644
--- a/themes/example_02/Makefile
+++ b/themes/example_02/Makefile
@@ -16,7 +16,7 @@ bootlogo: example_*.bc font
$(GFXBOOT) --archive $@.dir --pack-archive $@
font:
- $(GFXBOOT_FONT) -v -f DejaVuSans:size=20 font.fnt >font.log
+ $(GFXBOOT_FONT) -v -p /usr/share/fonts/truetype/ttf-dejavu -f DejaVuSans:size=20 font.fnt >font.log
clean:
rm -rf *~ *.log *.dir bootlogo *.fnt
diff --git a/themes/example_03/Makefile b/themes/example_03/Makefile
index cffce2e..4e18e35 100644
--- a/themes/example_03/Makefile
+++ b/themes/example_03/Makefile
@@ -16,7 +16,7 @@ bootlogo: example_*.bc font
$(GFXBOOT) --archive $@.dir --pack-archive $@
font:
- $(GFXBOOT_FONT) -v -f DejaVuSans:size=20 font.fnt >font.log
+ $(GFXBOOT_FONT) -v -p /usr/share/fonts/truetype/ttf-dejavu -f DejaVuSans:size=20 font.fnt >font.log
clean:
rm -rf *~ *.log *.dir bootlogo *.fnt
diff --git a/themes/example_04/Makefile b/themes/example_04/Makefile
index 07357a5..e54c817 100644
--- a/themes/example_04/Makefile
+++ b/themes/example_04/Makefile
@@ -16,7 +16,7 @@ bootlogo: example_*.bc font
$(GFXBOOT) --archive $@.dir --pack-archive $@
font:
- $(GFXBOOT_FONT) -v -f DejaVuSans:size=32 font.fnt >font.log
+ $(GFXBOOT_FONT) -v -p /usr/share/fonts/truetype/ttf-dejavu -f DejaVuSans:size=32 font.fnt >font.log
clean:
rm -rf *~ *.log *.dir bootlogo *.fnt
diff --git a/themes/example_05/Makefile b/themes/example_05/Makefile
index 07357a5..e54c817 100644
--- a/themes/example_05/Makefile
+++ b/themes/example_05/Makefile
@@ -16,7 +16,7 @@ bootlogo: example_*.bc font
$(GFXBOOT) --archive $@.dir --pack-archive $@
font:
- $(GFXBOOT_FONT) -v -f DejaVuSans:size=32 font.fnt >font.log
+ $(GFXBOOT_FONT) -v -p /usr/share/fonts/truetype/ttf-dejavu -f DejaVuSans:size=32 font.fnt >font.log
clean:
rm -rf *~ *.log *.dir bootlogo *.fnt
diff --git a/themes/example_06/Makefile b/themes/example_06/Makefile
index bf21c5d..0a3c7cd 100644
--- a/themes/example_06/Makefile
+++ b/themes/example_06/Makefile
@@ -20,7 +20,7 @@ bootlogo: example_*.bc font
@ln -snf bootlogo message
font:
- $(GFXBOOT_FONT) -v -f DejaVuSans:size=32 font.fnt >font.log
+ $(GFXBOOT_FONT) -v -p /usr/share/fonts/truetype/ttf-dejavu -f DejaVuSans:size=32 font.fnt >font.log
clean:
rm -rf *~ *.log *.dir bootlogo message *.fnt
diff --git a/themes/example_07/Makefile b/themes/example_07/Makefile
index bf21c5d..0a3c7cd 100644
--- a/themes/example_07/Makefile
+++ b/themes/example_07/Makefile
@@ -20,7 +20,7 @@ bootlogo: example_*.bc font
@ln -snf bootlogo message
font:
- $(GFXBOOT_FONT) -v -f DejaVuSans:size=32 font.fnt >font.log
+ $(GFXBOOT_FONT) -v -p /usr/share/fonts/truetype/ttf-dejavu -f DejaVuSans:size=32 font.fnt >font.log
clean:
rm -rf *~ *.log *.dir bootlogo message *.fnt