summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-01-03 03:06:43 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-01-03 17:44:53 -0800
commit8d81c8d27ee056510bd0dee3fa8ef7fb62f7b4cd (patch)
treeea309cf2aadd5ad92aab5d83b491624355e305fa /debian/rules
parent0ee440c4c5b144b32e1c7b7f1421140fa04fa911 (diff)
debian/rules: create empty changelog
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 19091dc..956b61c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,7 +13,10 @@ GFXBOOT_PATH = $(CURDIR)
VERSION:
echo $(DEB_VERSION_UPSTREAM) > VERSION
-override_dh_auto_build: VERSION
+changelog:
+ touch changelog
+
+override_dh_auto_build: VERSION changelog
dh_auto_build -- CFLAGS="$(CFLAGS) $(CPPFLAGS)"
LC_ALL=C.UTF-8 $(MAKE) -C doc doc
@@ -49,7 +52,7 @@ override_dh_auto_clean:
$(MAKE) -C doc clean
rm -rf build
- rm -f VERSION
+ rm -f VERSION changelog
override_dh_auto_install:
dh_auto_install