summaryrefslogtreecommitdiff
path: root/debian/patches/0004-link-order.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0004-link-order.patch')
-rw-r--r--debian/patches/0004-link-order.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0004-link-order.patch b/debian/patches/0004-link-order.patch
new file mode 100644
index 0000000..d9772c1
--- /dev/null
+++ b/debian/patches/0004-link-order.patch
@@ -0,0 +1,21 @@
+From: Colin Watson <cjwatson@ubuntu.com>
+Date: Sun, 3 Jan 2021 02:06:39 -0800
+Subject: Fix link order with 'ld --as-needed' (Closes: #605771).
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 6921559..54af87c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ changelog: $(GITDEPS)
+ $(GIT2LOG) --changelog changelog
+
+ gfxboot-font: gfxboot-font.c
+- $(CC) $(CFLAGS) -I /usr/include/freetype2 -lfreetype $< -o $@
++ $(CC) $(CFLAGS) -I /usr/include/freetype2 $< -lfreetype -o $@
+
+ gfxboot-compile: gfxboot-compile.c vocabulary.h bincode.h
+ $(CC) $(CFLAGS) $< -o $@