summaryrefslogtreecommitdiff
path: root/themes/test1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'themes/test1/Makefile')
-rw-r--r--themes/test1/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/themes/test1/Makefile b/themes/test1/Makefile
new file mode 100644
index 0000000..46baaa4
--- /dev/null
+++ b/themes/test1/Makefile
@@ -0,0 +1,23 @@
+BINDIR := $(shell [ -x ../../mkbootmsg ] && echo ../../ )
+MKBOOTMSG = $(BINDIR)mkbootmsg
+BFLAGS = -O -v -L ../..
+
+ifneq ($(BINDIR),)
+ BM_TARGET := $(MKBOOTMSG)
+endif
+
+.PHONY: all themes clean distclean
+
+all: themes
+
+themes: bootlogo
+
+bootlogo: test.ps $(BM_TARGET)
+ $(MKBOOTMSG) $(BFLAGS) -l log -c $< init
+ echo -e "init\njaguar.pcx" | cpio -o >bootlogo
+
+clean:
+ rm -f *~ log init bootlogo
+
+distclean: clean
+