summaryrefslogtreecommitdiff
path: root/themes/test5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'themes/test5/Makefile')
-rw-r--r--themes/test5/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/themes/test5/Makefile b/themes/test5/Makefile
new file mode 100644
index 0000000..a1672d1
--- /dev/null
+++ b/themes/test5/Makefile
@@ -0,0 +1,28 @@
+BINDIR := $(shell [ -x ../../gfxboot-compile ] && echo ../../ )
+MKBOOTMSG = $(BINDIR)gfxboot-compile
+BFLAGS = -O -v -L ../..
+
+ifneq ($(BINDIR),)
+ BM_TARGET := $(MKBOOTMSG)
+endif
+
+.PHONY: all prep themes clean distclean
+
+all: themes
+
+prep:
+
+themes: bootlogo
+
+bootlogo: test.ps 16x16.fnt $(BM_TARGET)
+ $(MKBOOTMSG) $(BFLAGS) -l log -c $< init
+ echo -e "init\nsky.jpg\n16x16.fnt" | cpio -o >bootlogo
+
+16x16.fnt:
+ ../../gfxboot-font -v -l 24 -f DejaVuSans:size=20 16x16.fnt >16x16.fnt.log
+
+clean:
+ rm -f *~ log init bootlogo 16x16.*
+
+distclean: clean
+