summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Braun <d_braun@kabelmail.de>2022-06-14 18:25:48 +0200
committerDennis Braun <d_braun@kabelmail.de>2022-06-14 18:25:48 +0200
commit95e2dfaa332d732aebb2e65622bfcc002dac87bb (patch)
tree827ed2f36a3f06c70b7f2b1f7b0d6705e2ee8f2f
parentc53b081ba3668a15567699a398711e481798b2e6 (diff)
Refresh patchset, drop desktop file patch applied by upstream
-rw-r--r--debian/patches/03-system-rtaudio.patch4
-rw-r--r--debian/patches/04-system-json.patch101
-rw-r--r--debian/patches/06-system-jpg+png.patch6
-rw-r--r--debian/patches/desktop_improvements.patch29
-rw-r--r--debian/patches/series1
5 files changed, 81 insertions, 60 deletions
diff --git a/debian/patches/03-system-rtaudio.patch b/debian/patches/03-system-rtaudio.patch
index 4d06c21..66f4ec6 100644
--- a/debian/patches/03-system-rtaudio.patch
+++ b/debian/patches/03-system-rtaudio.patch
@@ -10,7 +10,7 @@ Index: giada/CMakeLists.txt
===================================================================
--- giada.orig/CMakeLists.txt
+++ giada/CMakeLists.txt
-@@ -204,7 +204,6 @@ list(APPEND SOURCES
+@@ -207,7 +207,6 @@ list(APPEND SOURCES
src/utils/fs.cpp
src/utils/ver.cpp
src/utils/string.cpp
@@ -18,7 +18,7 @@ Index: giada/CMakeLists.txt
src/deps/mcl-audio-buffer/src/audioBuffer.cpp)
list(APPEND PREPROCESSOR_DEFS)
-@@ -294,6 +293,15 @@ elseif (PkgConfig_FOUND)
+@@ -297,6 +296,15 @@ elseif (PkgConfig_FOUND)
endif()
endif()
diff --git a/debian/patches/04-system-json.patch b/debian/patches/04-system-json.patch
index 6f94946..412b678 100644
--- a/debian/patches/04-system-json.patch
+++ b/debian/patches/04-system-json.patch
@@ -4,45 +4,96 @@ Subject: Build against system-provided nlohmann/json
Origin: Debian
Forwarded: no
-Last-Update: 2020-04-02
-
-Last-Update: 2020-04-02
----
- src/core/conf.cpp | 2 +-
- src/core/midiMapper.h | 2 +-
- src/core/patch.cpp | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
+Last-Update: 2022-06-14
+Index: giada/src/core/conf.cpp
+===================================================================
--- giada.orig/src/core/conf.cpp
+++ giada/src/core/conf.cpp
-@@ -27,7 +27,7 @@
- #include "core/conf.h"
- #include "core/const.h"
- #include "core/types.h"
--#include "deps/json/single_include/nlohmann/json.hpp"
-+#include "nlohmann/json.hpp"
- #include "utils/fs.h"
- #include "utils/log.h"
+@@ -32,7 +32,7 @@
#include <FL/Fl.H>
+ #include <cassert>
+ #include <fstream>
+-#include <nlohmann/json.hpp>
++#include "nlohmann/json.hpp"
+ #include <string>
+
+ namespace nl = nlohmann;
+@@ -303,4 +303,4 @@ void Conf::sanitize()
+ data.midiPortOut = std::max(-1, data.midiPortOut);
+ data.midiPortIn = std::max(-1, data.midiPortIn);
+ }
+-} // namespace giada::m
+\ No newline at end of file
++} // namespace giada::m
+Index: giada/src/core/midiMapper.h
+===================================================================
--- giada.orig/src/core/midiMapper.h
+++ giada/src/core/midiMapper.h
-@@ -27,7 +27,7 @@
- #ifndef G_MIDIMAPPER_H
+@@ -28,7 +28,7 @@
#define G_MIDIMAPPER_H
--#include "deps/json/single_include/nlohmann/json.hpp"
+ #include "mapper.h"
+-#include <nlohmann/json.hpp>
+#include "nlohmann/json.hpp"
#include <string>
#include <vector>
+Index: giada/src/core/patch.cpp
+===================================================================
--- giada.orig/src/core/patch.cpp
+++ giada/src/core/patch.cpp
-@@ -26,7 +26,7 @@
-
- #include "patch.h"
- #include "core/mixer.h"
--#include "deps/json/single_include/nlohmann/json.hpp"
-+#include "nlohmann/json.hpp"
+@@ -29,7 +29,7 @@
#include "utils/log.h"
#include "utils/math.h"
#include <fstream>
+-#include <nlohmann/json.hpp>
++#include "nlohmann/json.hpp"
+
+ namespace nl = nlohmann;
+
+Index: giada/src/mapper.h
+===================================================================
+--- giada.orig/src/mapper.h
++++ giada/src/mapper.h
+@@ -27,7 +27,7 @@
+ #ifndef G_MAPPER_H
+ #define G_MAPPER_H
+
+-#include <nlohmann/json.hpp>
++#include "nlohmann/json.hpp"
+ #include <optional>
+ #include <string>
+ #include <vector>
+Index: giada/src/gui/langMapper.h
+===================================================================
+--- giada.orig/src/gui/langMapper.h
++++ giada/src/gui/langMapper.h
+@@ -28,7 +28,7 @@
+ #define G_LANGMAPPER_H
+
+ #include "mapper.h"
+-#include <nlohmann/json.hpp>
++#include "nlohmann/json.hpp"
+ #include <string>
+ #include <unordered_map>
+ #include <vector>
+Index: giada/CMakeLists.txt
+===================================================================
+--- giada.orig/CMakeLists.txt
++++ giada/CMakeLists.txt
+@@ -405,10 +405,10 @@ list(APPEND LIBRARIES fmt::fmt)
+
+ # nlohmann_json (embedded as git submodule)
+
+-set(JSON_Install OFF CACHE INTERNAL "") # No need to install it
+-set(JSON_BuildTests OFF CACHE INTERNAL "") # Don't build tests
+-add_subdirectory(src/deps/json)
+-list(APPEND LIBRARIES nlohmann_json::nlohmann_json)
++#set(JSON_Install OFF CACHE INTERNAL "") # No need to install it
++#set(JSON_BuildTests OFF CACHE INTERNAL "") # Don't build tests
++#add_subdirectory(src/deps/json)
++#list(APPEND LIBRARIES nlohmann_json::nlohmann_json)
+
+ # Catch (if tests enabled)
+
diff --git a/debian/patches/06-system-jpg+png.patch b/debian/patches/06-system-jpg+png.patch
index 0437243..7dd0fd2 100644
--- a/debian/patches/06-system-jpg+png.patch
+++ b/debian/patches/06-system-jpg+png.patch
@@ -8,9 +8,9 @@ Index: giada/CMakeLists.txt
===================================================================
--- giada.orig/CMakeLists.txt
+++ giada/CMakeLists.txt
-@@ -394,6 +394,9 @@ else()
- message("Libsamplerate library found in " ${LIBRARY_SAMPLERATE})
- endif()
+@@ -410,6 +410,9 @@ list(APPEND LIBRARIES fmt::fmt)
+ #add_subdirectory(src/deps/json)
+ #list(APPEND LIBRARIES nlohmann_json::nlohmann_json)
+pkg_check_modules(JpegPng IMPORTED_TARGET libjpeg libpng)
+list(APPEND LIBRARIES PkgConfig::JpegPng)
diff --git a/debian/patches/desktop_improvements.patch b/debian/patches/desktop_improvements.patch
deleted file mode 100644
index b5c104f..0000000
--- a/debian/patches/desktop_improvements.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Description: Add keywords and translations from old debian desktop file
- and add german translation
-Author: Dennis Braun <d_braun@kabelmail.de>
-Forwarded: yes
-
-Index: giada/extras/com.giadamusic.Giada.desktop
-===================================================================
---- giada.orig/extras/com.giadamusic.Giada.desktop
-+++ giada/extras/com.giadamusic.Giada.desktop
-@@ -2,11 +2,17 @@
- Version=1.0
- Type=Application
- Name=Giada
--Name[es]=Giada
- GenericName=Drum machine and loop sequencer
-+Comment=Drum machine and loop sequencer
-+GenericName[de]=Drum Maschine und Loop Sequenzer
- GenericName[es]=Caja de ritmos y secuenciador de loops
-+GenericName[fr]=Boîte à rythme et séquenceur de boucle
-+Comment=Drum machine and loop sequencer
-+Comment[de]=Drum Maschine und Loop Sequenzer
-+Comment[es]=Caja de ritmos y secuenciador de loops
-+Comment[fr]=Boîte à rythme et séquenceur de boucle
- Exec=giada %f
- Terminal=false
- Icon=com.giadamusic.Giada
- Categories=Music;AudioVideo;Audio;Midi;X-Digital_Processing;X-Jack;X-MIDI;
--Keywords=Giada;
-+Keywords=midi;jackd;alsa;pulse;audio;sound;loop;
diff --git a/debian/patches/series b/debian/patches/series
index 4ea11b6..1570baf 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
-desktop_improvements.patch
02-geompp.patch
03-system-rtaudio.patch
04-system-json.patch