summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIOhannes m zmölnig <umlaeute@debian.org>2021-12-23 12:58:30 +0100
committerIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2021-12-23 12:58:30 +0100
commit9d63917c56ae17ea10c48202f4f3910ca32faf01 (patch)
tree2e861343ef2a62ac1648eaa6bfb7f47d0b45b4bd
parent5e01fb3f93035cb92cb32ca5b3e3fedb796b8d1f (diff)
link against system libpng/libjpeg
Forwarded: not-needed Last-Update: 2021-12-20 Last-Update: 2021-12-20 Gbp-Pq: Name 06-system-jpg+png.patch
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbd2878..ea955d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -385,6 +385,9 @@ else()
message("Libsamplerate library found in " ${LIBRARY_SAMPLERATE})
endif()
+pkg_check_modules(JpegPng IMPORTED_TARGET libjpeg libpng)
+list(APPEND LIBRARIES PkgConfig::JpegPng)
+
# Catch (if tests enabled)
if (WITH_TESTS)