summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2023-01-11 17:29:59 +0100
committerIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2023-01-11 17:29:59 +0100
commitb98fe3eea15caf3895ec49256b0fb043891863cc (patch)
tree02f13d4f194ce06b7c178613b4f9644aebf4c4a7
parentb6df7a19c777a1399f1f9c400698279382e3d6ff (diff)
Link against libz
-rw-r--r--debian/patches/juce-7_0_2.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/patches/juce-7_0_2.patch b/debian/patches/juce-7_0_2.patch
index e223930..aac71ae 100644
--- a/debian/patches/juce-7_0_2.patch
+++ b/debian/patches/juce-7_0_2.patch
@@ -40,3 +40,13 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
bool canControlTransport() override;
private:
+--- giada.orig/CMakeLists.txt
++++ giada/CMakeLists.txt
+@@ -575,6 +575,7 @@
+ # ------------------------------------------------------------------------------
+ # Finalize 'giada' target (main executable).
+ # ------------------------------------------------------------------------------
++list(APPEND LIBRARIES z)
+
+ add_executable(giada)
+ target_compile_features(giada PRIVATE ${COMPILER_FEATURES})