summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDennis Braun <d_braun@kabelmail.de>2022-06-13 22:45:45 +0200
committerDennis Braun <d_braun@kabelmail.de>2022-06-13 22:45:45 +0200
commited972b70dcba4055781085ac5599730321b4ccdd (patch)
treee4c61b228ac66b83e30577e41d5b04f9bfae72e4 /CMakeLists.txt
parent6be2fd4da5ca72688c5363886c6d0842c9edb54e (diff)
New upstream version 0.22.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 22 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ec69d1..e66f0f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,7 @@ project(giada LANGUAGES CXX)
list(APPEND SOURCES
src/main.cpp
+ src/mapper.cpp
src/core/engine.cpp
src/core/worker.cpp
src/core/eventDispatcher.cpp
@@ -77,6 +78,7 @@ list(APPEND SOURCES
src/core/channels/midiSender.cpp
src/core/channels/midiReceiver.cpp
src/core/channels/channel.cpp
+ src/core/channels/channelShared.cpp
src/core/channels/channelManager.cpp
src/core/model/sequencer.cpp
src/core/model/mixer.cpp
@@ -99,6 +101,7 @@ list(APPEND SOURCES
src/gui/dialogs/window.cpp
src/gui/dispatcher.cpp
src/gui/updater.cpp
+ src/gui/langMapper.cpp
src/gui/drawing.cpp
src/gui/dialogs/progress.cpp
src/gui/dialogs/keyGrabber.cpp
@@ -139,7 +142,6 @@ list(APPEND SOURCES
src/gui/elems/sampleEditor/waveform.cpp
src/gui/elems/sampleEditor/waveTools.cpp
src/gui/elems/sampleEditor/volumeTool.cpp
- src/gui/elems/sampleEditor/boostTool.cpp
src/gui/elems/sampleEditor/panTool.cpp
src/gui/elems/sampleEditor/pitchTool.cpp
src/gui/elems/sampleEditor/rangeTool.cpp
@@ -177,6 +179,7 @@ list(APPEND SOURCES
src/gui/elems/config/tabBehaviors.cpp
src/gui/elems/config/tabPlugins.cpp
src/gui/elems/config/tabBindings.cpp
+ src/gui/elems/config/stringMenu.cpp
src/gui/elems/basics/scroll.cpp
src/gui/elems/basics/pack.cpp
src/gui/elems/basics/group.cpp
@@ -303,14 +306,15 @@ if (NOT RtMidi_FOUND)
message(FATAL_ERROR "Can't find RtMidi, aborting.")
endif()
- # RtMidi header path may vary across OSes, so a fix is needed.
- # TODO - Find a way to avoid this additional step
-
- find_path(LIBRARY_RTMIDI_INCLUDE_DIR RtMidi.h PATH_SUFFIXES rtmidi)
- list(APPEND INCLUDE_DIRS ${LIBRARY_RTMIDI_INCLUDE_DIR})
message("RtMidi library found in " ${RtMidi_DIR})
endif()
+# RtMidi header path may vary across OSes, so a fix is needed.
+# TODO - Find a way to avoid this additional step
+
+find_path(LIBRARY_RTMIDI_INCLUDE_DIR RtMidi.h PATH_SUFFIXES rtmidi)
+list(APPEND INCLUDE_DIRS ${LIBRARY_RTMIDI_INCLUDE_DIR})
+
# FLTK
set(FLTK_SKIP_FLUID TRUE) # Don't search for FLTK's fluid
@@ -386,6 +390,18 @@ else()
message("Libsamplerate library found in " ${LIBRARY_SAMPLERATE})
endif()
+# fmt
+
+find_package(fmt REQUIRED)
+list(APPEND LIBRARIES fmt::fmt)
+
+# nlohmann_json (embedded as git submodule)
+
+set(JSON_Install OFF CACHE INTERNAL "") # No need to install it
+set(JSON_BuildTests OFF CACHE INTERNAL "") # Don't build tests
+add_subdirectory(src/deps/json)
+list(APPEND LIBRARIES nlohmann_json::nlohmann_json)
+
# Catch (if tests enabled)
if (WITH_TESTS)