summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt8
-rw-r--r--src/core/conf.cpp4
-rw-r--r--src/core/midiMapper.h2
-rw-r--r--src/core/patch.cpp2
-rw-r--r--src/gui/langMapper.h2
-rw-r--r--src/mapper.h2
6 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f849e38..10aa3bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -405,10 +405,10 @@ list(APPEND LIBRARIES fmt::fmt)
# nlohmann_json (embedded as git submodule)
-set(JSON_Install OFF CACHE INTERNAL "") # No need to install it
-set(JSON_BuildTests OFF CACHE INTERNAL "") # Don't build tests
-add_subdirectory(src/deps/json)
-list(APPEND LIBRARIES nlohmann_json::nlohmann_json)
+#set(JSON_Install OFF CACHE INTERNAL "") # No need to install it
+#set(JSON_BuildTests OFF CACHE INTERNAL "") # Don't build tests
+#add_subdirectory(src/deps/json)
+#list(APPEND LIBRARIES nlohmann_json::nlohmann_json)
# Catch (if tests enabled)
diff --git a/src/core/conf.cpp b/src/core/conf.cpp
index 462e514..a7fe3c0 100644
--- a/src/core/conf.cpp
+++ b/src/core/conf.cpp
@@ -32,7 +32,7 @@
#include <FL/Fl.H>
#include <cassert>
#include <fstream>
-#include <nlohmann/json.hpp>
+#include "nlohmann/json.hpp"
#include <string>
namespace nl = nlohmann;
@@ -303,4 +303,4 @@ void Conf::sanitize()
data.midiPortOut = std::max(-1, data.midiPortOut);
data.midiPortIn = std::max(-1, data.midiPortIn);
}
-} // namespace giada::m \ No newline at end of file
+} // namespace giada::m
diff --git a/src/core/midiMapper.h b/src/core/midiMapper.h
index 8bcd890..e19c39b 100644
--- a/src/core/midiMapper.h
+++ b/src/core/midiMapper.h
@@ -28,7 +28,7 @@
#define G_MIDIMAPPER_H
#include "mapper.h"
-#include <nlohmann/json.hpp>
+#include "nlohmann/json.hpp"
#include <string>
#include <vector>
diff --git a/src/core/patch.cpp b/src/core/patch.cpp
index bfeb64c..fd28dc3 100644
--- a/src/core/patch.cpp
+++ b/src/core/patch.cpp
@@ -29,7 +29,7 @@
#include "utils/log.h"
#include "utils/math.h"
#include <fstream>
-#include <nlohmann/json.hpp>
+#include "nlohmann/json.hpp"
namespace nl = nlohmann;
diff --git a/src/gui/langMapper.h b/src/gui/langMapper.h
index 48f90cd..c78a37b 100644
--- a/src/gui/langMapper.h
+++ b/src/gui/langMapper.h
@@ -28,7 +28,7 @@
#define G_LANGMAPPER_H
#include "mapper.h"
-#include <nlohmann/json.hpp>
+#include "nlohmann/json.hpp"
#include <string>
#include <unordered_map>
#include <vector>
diff --git a/src/mapper.h b/src/mapper.h
index c22f13f..b5e720d 100644
--- a/src/mapper.h
+++ b/src/mapper.h
@@ -27,7 +27,7 @@
#ifndef G_MAPPER_H
#define G_MAPPER_H
-#include <nlohmann/json.hpp>
+#include "nlohmann/json.hpp"
#include <optional>
#include <string>
#include <vector>