summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-01-17 14:48:56 -0400
committerJoey Hess <joey@kitenet.net>2014-01-17 14:48:56 -0400
commit3cbb366ebcdd7c9db52aa4c1aec342876c5decd8 (patch)
treeaf974c200823e88434d30bae7787a899c5ed3414
parent9a5944c4148f058be7c49ed2a868e453526ff1e9 (diff)
Really fix FTBFS on mipsel and sparc due to test suite not being available on those architectures.debian/5.20140117
-rw-r--r--Command/Test.hs12
-rw-r--r--GitAnnex.hs2
-rw-r--r--debian/changelog7
-rw-r--r--git-annex.cabal2
4 files changed, 17 insertions, 6 deletions
diff --git a/Command/Test.hs b/Command/Test.hs
index d4fa5eb5b3..be480eeb71 100644
--- a/Command/Test.hs
+++ b/Command/Test.hs
@@ -7,11 +7,12 @@
module Command.Test where
+import Common
import Command
import Messages
def :: [Command]
-def = [ dontCheck repoExists $
+def = [ noRepo startIO $ dontCheck repoExists $
command "test" paramNothing seek SectionPlumbing
"run built-in test suite"]
@@ -28,7 +29,10 @@ seek = [withWords start]
- test suite.
-}
start :: [String] -> CommandStart
-start [] = do
- warning "git-annex was built without its test suite; not testing"
+start ps = do
+ liftIO $ startIO ps
stop
-start _ = error "Cannot specify any additional parameters when running test"
+
+startIO :: CmdParams -> IO ()
+startIO [] = warningIO "git-annex was built without its test suite; not testing"
+startIO _ = error "Cannot specify any additional parameters when running test"
diff --git a/GitAnnex.hs b/GitAnnex.hs
index 5de823e16f..4c1649ba14 100644
--- a/GitAnnex.hs
+++ b/GitAnnex.hs
@@ -164,8 +164,8 @@ cmds = concat
, Command.XMPPGit.def
#endif
#endif
-#ifdef WITH_TESTSUITE
, Command.Test.def
+#ifdef WITH_TESTSUITE
, Command.FuzzTest.def
#endif
]
diff --git a/debian/changelog b/debian/changelog
index 36523ce046..e1853da5b6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+git-annex (5.20140117) unstable; urgency=medium
+
+ * Really fix FTBFS on mipsel and sparc due to test suite not being available
+ on those architectures.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 17 Jan 2014 14:46:27 -0400
+
git-annex (5.20140116) unstable; urgency=medium
* Added tahoe special remote.
diff --git a/git-annex.cabal b/git-annex.cabal
index 034e70ee10..9b4edf8b2d 100644
--- a/git-annex.cabal
+++ b/git-annex.cabal
@@ -1,5 +1,5 @@
Name: git-annex
-Version: 5.20140116
+Version: 5.20140117
Cabal-Version: >= 1.8
License: GPL-3
Maintainer: Joey Hess <joey@kitenet.net>