summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2016-10-29 17:14:50 +0200
committerAndrew Shadura <andrewsh@debian.org>2016-10-29 17:14:50 +0200
commit94592799c9835a593300c229a0d43a76f53b56c1 (patch)
treed60590642208eed466045e26d3e68c6c0ecfc0ec /debian
parentf915b614a869a0f3610c2fc76d6105da2e28b306 (diff)
Prepare to use pybuild.debian/1.0.0-3
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control8
-rwxr-xr-xdebian/rules9
3 files changed, 16 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 91a3910..2473a80 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+git-phab (1.0.0-3) unstable; urgency=medium
+
+ * Prepare to use pybuild.
+
+ -- Andrew Shadura <andrewsh@debian.org> Sat, 29 Oct 2016 17:14:38 +0200
+
git-phab (1.0.0-2) unstable; urgency=medium
[ Logan Rosen ]
diff --git a/debian/control b/debian/control
index 9cd06e8..effaf9c 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,9 @@ Maintainer: Héctor Orón Martínez <zumbi@debian.org>
Uploaders: Andrew Shadura <andrewsh@debian.org>
Build-Depends: debhelper (>= 9),
bash-completion,
+ dh-python,
+ python3-all,
+ python3-setuptools (>= 0.6.24),
# Needed for manpage
asciidoc,
libxml2-utils,
@@ -18,8 +21,9 @@ Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/git-phab.git
Package: git-phab
Architecture: all
-Depends: ${misc:Depends},
- python3,
+Depends:
+ ${misc:Depends},
+ ${python3:Depends},
python3-appdirs,
python3-argcomplete,
python3-git,
diff --git a/debian/rules b/debian/rules
index c0e91b2..67ffe87 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,9 @@
#!/usr/bin/make -f
-DH_VERBOSE=1
-%:
- dh $@
+export PYBUILD_DISABLE=clean configure build install
-override_dh_auto_clean override_dh_auto_build override_dh_auto_install:
+%:
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_installman:
a2x --doctype manpage --format manpage git-phab.txt
@@ -16,4 +15,4 @@ get-orig-source: VERSION:=$(shell dpkg-parsechangelog -S Version | cut -d - -f 1
get-orig-source:
git archive -9 --format=tar.xz --prefix=git-phab-$(VERSION)/ -o git-phab-$(VERSION).tar.xz upstream/$(VERSION)
-.PHONY: override_dh_auto_clean override_dh_auto_build override_dh_auto_install override_dh_installman get-orig-source
+.PHONY: override_dh_installman get-orig-source