summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2016-10-20 12:51:11 +0200
committerAndrew Shadura <andrewsh@debian.org>2016-10-24 17:19:24 +0200
commitb987a81daf0eac6455ff2bfe89acce5f51ecf739 (patch)
tree6f51ff4ebcdb2c9fc4900b6a8e8a9a3fa6081f51 /debian
parentb788ed9be2319be906b00e04d56751714214d2e1 (diff)
Add get-orig-source
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 91a4f63..2c001ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,3 +8,10 @@ override_dh_installman:
a2x --doctype manpage --format manpage git-phab.txt
dh_bash-completion
dh_installman
+
+get-orig-source: VERSION:=$(shell dpkg-parsechangelog -S Version | cut -d - -f 1 | tr '~' _)
+
+get-orig-source:
+ git archive -9 --format=tar.xz --prefix=git-phab-$(VERSION)/ -o git-phab-$(VERSION).tar.xz upstream/$(VERSION)
+
+.PHONY: override_dh_installman get-orig-source