summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHéctor Orón Martínez <zumbi@debian.org>2016-03-22 12:31:49 +0100
committerHéctor Orón Martínez <zumbi@debian.org>2016-03-22 17:23:06 +0100
commitcc587d1cb3923384d94494d66558ec5da712b2bf (patch)
treeb7e513a87159167d5e844246d22a73ac43d9ffc2 /debian
parent6b53da59062356dbe49707da45edfde122441864 (diff)
Initial Debian packaging
Signed-off-by: Héctor Orón Martínez <zumbi@debian.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/bash_completion.d/git-phab7
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control26
-rw-r--r--debian/copyright34
-rw-r--r--debian/docs1
-rw-r--r--debian/git-phab.bash-completion1
-rw-r--r--debian/install1
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules14
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options1
12 files changed, 93 insertions, 0 deletions
diff --git a/debian/bash_completion.d/git-phab b/debian/bash_completion.d/git-phab
new file mode 100644
index 0000000..6603f72
--- /dev/null
+++ b/debian/bash_completion.d/git-phab
@@ -0,0 +1,7 @@
+function _git_phab()
+{
+ COMP_WORDS=(git-phab ${COMP_WORDS[@]:2})
+ COMP_CWORD=$((COMP_CWORD - 1))
+ COMP_LINE=${COMP_LINE/git phab/git-phab}
+ _python_argcomplete_global git-phab
+
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..a9c53e7
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+git-phab (0~git20151211-1) unstable; urgency=low
+
+ * Initial release (Closes: #818975)
+
+ -- Héctor Orón Martínez <zumbi@debian.org> Tue, 22 Mar 2016 16:03:22 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..1f4e2b6
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,26 @@
+Source: git-phab
+Section: utils
+Priority: extra
+Maintainer: Héctor Orón Martínez <zumbi@debian.org>
+Build-Depends: debhelper (>= 9),
+ bash-completion,
+# Needed for manpage
+ asciidoc,
+ libxml2-utils,
+ docbook-xml,
+ xsltproc
+Standards-Version: 3.9.7
+Homepage: https://phabricator.freedesktop.org/diffusion/GITPHAB/
+Vcs-Git: https://anonscm.debian.org/git/collab-maint/git-phab.git
+Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/git-phab.git
+
+Package: git-phab
+Architecture: all
+Depends: ${misc:Depends},
+ python3,
+ python3-appdirs,
+ python3-argcomplete,
+ python3-git,
+ arcanist
+Description: Git subcommand to integrate with Phabricator.
+ Tool to help out pushing Git changes into Phabricator Differential.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..c7b99b4
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,34 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: git-phab
+Source: https://cgit.freedesktop.org/git-phab/
+
+Files: *
+Copyright: Copyright (C) 2008 Owen Taylor
+ Copyright (C) 2015 Xavier Claessens <xavier.claessens@collabora.com>
+License: GPL-2+
+
+Files: debian/*
+Copyright: 2015 Héctor Orón Martínez <hector.oron@collabora.co.uk>
+License: LGPL-2.1+
+
+License: LGPL-2.1+
+ This library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License.
+ .
+ This library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+ .
+ You should have received a copy of the GNU Lesser General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ .
+ The complete text of the GNU Lesser General Public License
+ can be found in /usr/share/common-licenses/LGPL-2.1 file.
+
+License: GPL-2+
+ On Debian GNU/Linux systems, the complete text of version 2 of
+ the GNU General Public License can be found in
+ `/usr/share/common-licenses/GPL-2'.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/git-phab.bash-completion b/debian/git-phab.bash-completion
new file mode 100644
index 0000000..4a9c5eb
--- /dev/null
+++ b/debian/git-phab.bash-completion
@@ -0,0 +1 @@
+debian/bash_completion.d/git-phab
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..ef18632
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+git-phab usr/bin
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..395b4b9
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+git-phab.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b4008b5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+DH_VERBOSE=1
+
+%:
+ dh $@
+
+override_dh_installman:
+ a2x --doctype manpage --format manpage git-phab.txt
+ dh_bash-completion
+ dh_installman
+
+override_dh_clean:
+ rm -f git-phab.1
+ dh_clean
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 0000000..4271bfc
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1 @@
+extend-diff-ignore = ^git\.mk$|^\.arcconfig$|^ChangeLog$|^\.arclint$