summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2019-02-25 16:51:42 +0000
committerSimon McVittie <smcv@debian.org>2019-02-25 16:51:42 +0000
commit17e328fdb863d3adebbd2ad79650d8ba2b5bebb9 (patch)
treefdf53c116fb499a404b00f95f8c8dbc7a41fd274
parentb5b050fa2ae76e94f694c25614710df2a21a0378 (diff)
Add a trivial build system
-rw-r--r--debian/patches/Add-a-build-system-for-gschemas.compiled.patch39
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules3
3 files changed, 40 insertions, 3 deletions
diff --git a/debian/patches/Add-a-build-system-for-gschemas.compiled.patch b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
new file mode 100644
index 0000000..9df15d1
--- /dev/null
+++ b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
@@ -0,0 +1,39 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Mon, 25 Feb 2019 15:16:09 +0000
+Subject: Add a build system for gschemas.compiled
+
+Instead of including it in the git repository, build it from its source
+code (the XML) as needed.
+---
+ .gitignore | 1 +
+ Makefile | 14 ++++++++++++++
+ 2 files changed, 15 insertions(+)
+ create mode 100644 Makefile
+
+diff --git a/.gitignore b/.gitignore
+index a09c56d..e666a92 100644
+--- a/.gitignore
++++ b/.gitignore
+@@ -1 +1,2 @@
+ /.idea
++/schemas/gschemas.compiled
+diff --git a/Makefile b/Makefile
+new file mode 100644
+index 0000000..b34acee
+--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,14 @@
++# Copyright 2019 Simon McVittie
++# SPDX-License-Identifier: GPL-2.0-or-later
++# (see extension.js for details)
++
++all:
++ glib-compile-schemas --strict --targetdir=schemas schemas
++
++dist: all
++ zip gnome-bluetooth-quick-connect.zip -9r *
++
++clean:
++ rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
++
++.PHONY: all clean dist
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..649c386
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+Add-a-build-system-for-gschemas.compiled.patch
diff --git a/debian/rules b/debian/rules
index 14ae554..3c746ff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,3 @@ include /usr/share/dpkg/default.mk
%:
dh $@
-
-override_dh_auto_build:
- glib-compile-schemas --strict --targetdir=schemas schemas