summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2019-02-25 15:16:09 +0000
committerSimon McVittie <smcv@debian.org>2019-02-25 16:53:48 +0000
commit8f6b7cc4afb69efff92359ff4968cfe240bd59b2 (patch)
treeacc897596398eb476dfa961f6aba522d81712f4b
parent057b524158f12228927466e2e8be7f7cac3fc5be (diff)
Add a build system for gschemas.compiled
Instead of including it in the git repository, build it from its source code (the XML) as needed. Gbp-Pq: Name Add-a-build-system-for-gschemas.compiled.patch
-rw-r--r--.gitignore1
-rw-r--r--Makefile14
2 files changed, 15 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index a09c56d..e666a92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
/.idea
+/schemas/gschemas.compiled
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b34acee
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+# Copyright 2019 Simon McVittie
+# SPDX-License-Identifier: GPL-2.0-or-later
+# (see extension.js for details)
+
+all:
+ glib-compile-schemas --strict --targetdir=schemas schemas
+
+dist: all
+ zip gnome-bluetooth-quick-connect.zip -9r *
+
+clean:
+ rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
+
+.PHONY: all clean dist